POJ-Subsequence(3061)——尺取法求最小和区间

Description

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3

 

题目分析:

  • 采用尺取法,这里用num数组表示前n项和,需要用到num[ 0 ]=0,因为num[ n ] - num[ 0 ]不会漏掉第一项。
  • num[ a ] - num[ b ]表示取出( b , a ]区间的值。
  • 指定两个指针f,e分别表示左指针和右指针,初始化f,e为0。

 

算法描述:

  1. 设s为所求区间和,n为区间长度,不断右移e指针直到num[ a ] - num[ b ] >= s。
  2. 当num[ a ] - num[ b ] >= s时不断右移f指针,记录e-f的最小值。
  3. 当e>n时,循环结束,否则,回到第1步。
  4. 输出e-f的最小值。

 

AC代码:

#include <iostream>
#include <algorithm>
using namespace std;
int num[100001];//前n项和 
void solve(int n,int s){
	int f=0,e=0,inp;//左右指针,输入 
	int mmin=0;//默认找不到输出0 
	for(int i=1;i<=n;i++){
		cin>>inp;
		num[i]=num[i-1]+inp;//累加 
	}
	while(e<=n){//循环结束条件 
		while(num[e]-num[f]<s&&e<=n){
			e++;//右指针右移 
		}
		if(e>n) break;//超界退出循环 
		while(num[e]-num[f]>=s){
			if(!mmin) mmin=e-f;//记录最小值 
			else mmin=min(mmin,e-f);
			f++;
			//cout<<f<<' '<<e<<endl;
		}
	}
	cout<<mmin<<endl;//输出 
}
int main(){
	int t;
	cin>>t;//测试样例 
	num[0]=0;
	while(t--){
		int n,s;
		cin>>n>>s;//输入 
		solve(n,s);
	}
	return 0;
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

cout0

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值