[UVA 10891] Game of Sum

博弈DP

This is a two player game. Initially there are n integer numbers in an array and players A and B get chance to take them alternatively. Each player can take one or more numbers from the left or right end of the array but cannot take from both ends at a time. He can take as many consecutive numbers a she wants during his time. The game ends when all numbers are taken from the array by the players.The point of each player is calculated by the summation of the numbers, which he has taken. Each player tries to achieve more points from other. If both players play optimally and player A starts the game then how much more point can player A get than player B?

Input

The input consists of a number of cases. Each case starts with a line specifying the integer n (0 <n ≤ 100), the number of elements in the array. After that, n numbers are given for the game. Input is terminated by a line where n = 0.

Output

For each test case, print a number, which represents the maximum difference that the first player obtained after playing this game optimally.

Sample Input

4

4 -10 -20 7

4 1 2 3 4

0

Sample Output

7

10


刚开始看错题目了……玩家取数的规则是取走一个前缀或者一个后缀, 不能从中间取一段……


dp[i][j] 表示在区间[ i , j ] 中, 先手能取得的最大分。 枚举中间断点 k , 先手可能有两种决策,取走[ i , k ] 的所有数, 再令状态转移到 dp[k+1][j] ,得分 sum( i, k ) + sum( k+1, j ) - dp[k+1][j] , 或者取走[ k+1, j ] 所有数, 状态转移到 dp[i][k] , 得分sum( k+1, j ) + sum ( i, k ) - dp[i][k] 。 取所有k的最大。


#include <cstdio>
#include <cstdlib>
#include <cstring>

using namespace std;
#define INF 999999
inline int maxx(int a, int b){return a>b ? a: b;}
inline int minn(int a, int b){return a<b ? a: b;}
inline int abss(int a){return a<0? (-a):a;}
int n;
int inpt[110];
int dp[110][110];
int sum[110];
int main()
{
	while(scanf("%d", &n) != EOF && n)
	{
		for(int i=1; i<=n; i++)
		{
			scanf("%d", &inpt[i]);
			sum[i] = sum[i-1] + inpt[i];
		}

		for(int len=1; len<=n; len++)
		{
			for(int i=1; i<=n-len+1; i++)
			{
				int j=i+len-1;
				if(i == j)
				{
					dp[i][j] = inpt[i];
					continue;
				}
				int now = -INF;
				for(int k=i; k<j; k++)
				{
					int tem = minn(dp[i][k], dp[k+1][j]);
					now = maxx(now, sum[j]-sum[i-1]-tem); 
				}

				dp[i][j] = maxx(now, sum[j]-sum[i-1]);
			}
		}

		printf("%d\n", 2*dp[1][n]-sum[n]);

	}

	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值