hoj 1797 Red and Black

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.


Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and HW and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

  • '.' - a black tile
  • '#' - a red tile
  • '@' - a man on a black tile(appears exactly once in a data set)


Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0
Sample Output
45
59
6
13

大致题意:有两种瓷砖红瓷砖('#')和黑瓷砖('.')。有一人在房间中(起始位置在'@'处)只能站在黑瓷砖中,能上下左右四个方向移动,并且只能从黑瓷砖走到黑瓷砖上,求这个人能重复移动所到达的黑瓷砖的数目。

大致思路:深搜,每一次dfs将他四个方向的一个黑瓷砖变成红瓷砖,dfs的次数即为所能到达的黑瓷砖的总数。由于起始位置也为黑瓷砖最后的结果记得+1。

注意在输入的时候要用getchar()吃掉一个回车符。

具体实现如下:

#define _CRT_SECURE_NO_WARNINGS
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#define N 20 + 2
char buf[N][N];
int ans;
void InputData(int m,int n,int *x,int *y)
{
	int i, j;
	memset(buf, 0, sizeof(buf));
	for (i = 0; i < n; i++)
	{
		getchar();
		for (j = 0; j < m; j++)
		{
			scanf("%c", &buf[i][j]);
			if (buf[i][j] == '@')
				*x = i, *y = j;
		}
	}
}
void dfs(int x, int y)
{
	buf[x][y] = '#';
	int i, dx[4] = { -1, 1, 0, 0 }, dy[4] = { 0, 0, 1, -1 };
	for (i = 0; i < 4; i++)
	{
		int nx = x + dx[i], ny = y + dy[i];
		if (x >= 0 && x < N && y >= 0 && y < N && buf[nx][ny] == '.')
		{
			ans++;
			dfs(nx, ny);
		}
	}
}
void solve(int m, int n)
{
	int x = 0, y = 0;
	InputData(m, n,&x,&y);
	ans = 1;
	dfs(x, y);
	printf("%d\n",ans);
}
int main()
{
	int m, n;
	while (EOF != scanf("%d %d", &m, &n) && 0!=m && 0!=n)
		solve(m, n);
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值