HDU 2952 Counting Sheep (深度搜索)

Counting Sheep

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1753    Accepted Submission(s): 1143



Problem Description
A while ago I had trouble sleeping. I used to lie awake, staring at the ceiling, for hours and hours. Then one day my grandmother suggested I tried counting sheep after I'd gone to bed. As always when my grandmother suggests things, I decided to try it out. The only problem was, there were no sheep around to be counted when I went to bed.


Creative as I am, that wasn't going to stop me. I sat down and wrote a computer program that made a grid of characters, where # represents a sheep, while . is grass (or whatever you like, just not sheep). To make the counting a little more interesting, I also decided I wanted to count flocks of sheep instead of single sheep. Two sheep are in the same flock if they share a common side (up, down, right or left). Also, if sheep A is in the same flock as sheep B, and sheep B is in the same flock as sheep C, then sheeps A and C are in the same flock.


Now, I've got a new problem. Though counting these sheep actually helps me fall asleep, I find that it is extremely boring. To solve this, I've decided I need another computer program that does the counting for me. Then I'll be able to just start both these programs before I go to bed, and I'll sleep tight until the morning without any disturbances. I need you to write this program for me.
 

Input
The first line of input contains a single number T, the number of test cases to follow.

Each test case begins with a line containing two numbers, H and W, the height and width of the sheep grid. Then follows H lines, each containing W characters (either # or .), describing that part of the grid.
 

Output
For each test case, output a line containing a single number, the amount of sheep flock son that grid according to the rules stated in the problem description.

Notes and Constraints
0 < T <= 100
0 < H,W <= 100
 

Sample Input
  
  
2 4 4 #.#. .#.# #.## .#.# 3 5 ###.# ..#.. #.###
 

Sample Output
  
  
6 3
 

Source
 

Recommend
gaojie

题意:
有一块大草原,草原上有草有羊,“#”符号表示羊,“.”符号表示草。需要回答在这个大草坪中有几个羊群。
羊群的定义:某羊群中的任意两只羊都可通过相邻边联系在一起,当然也可能是仅有一只羊。
思路:
可使用深度搜索的方法解题。

/*************************************************************************
	> File Name: JJ.cpp
	> Author: BSlin
	> Mail:  
	> Created Time: 2013年09月26日 星期四 17时44分42秒
 ************************************************************************/

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <cstdlib>
#include <cmath>
#include <algorithm>
#include <iterator>
#include <vector>
#include <map>
#include <set>
#include <stack>
#include <queue>
#define MP make_pair
#define INF (1<<30)
#define PI acos(-1.0)
#define esp 1e-8
const int dx[4]={0,0,0,0};
using namespace std;
#define read freopen("in.txt","r",stdin)
#define write freopen("out.txt","w",stdout)
#if defined (_WIN32) || defined (__WIN32) || defined (WIN32) || defined (__WIN32__)
#define LL __int64
#define LLS "%" "I" "6" "4" "d"
#else
#define LL long long
#define LLS "%" "l" "l" "d"
#endif



char map1[110][110];
int n,m;
int to[4][2] = {0,1,-1,0,0,-1,1,0};

bool inmap(int x, int y) {
    if(x >= 1 && x <= n && y >= 1 && y <= m) return true;
    return false;
}

void dfs(int x, int y) {
    int i,nowx,nowy;
    for(i=0; i<4; i++) {
        nowx = x + to[i][0];
        nowy = y + to[i][1];
        if(!inmap(nowx,nowy) || map1[nowx][nowy] == '.') continue;
        map1[nowx][nowy] =  '.';
        dfs(nowx,nowy);
    }
}

int main(int argc, char** argv) {
    //read;
    int t,i,j,k,cnt;
    scanf("%d",&t);
    while(t--) {
        scanf("%d %d\n",&n,&m);
        cnt = 0;
        k = 0;
        for(i=1; i<=n; i++) {
            for(j=1; j<=m; j++) {
                scanf("%c",&map1[i][j]);
            }
            getchar();
        }
        for(i=1; i<=n; i++) {
            for(j=1; j<=m;j++) {
                if(map1[i][j] == '#') {
                    cnt++;
                    map1[i][j] = '.';
                    dfs(i,j);
                }
            }
        }
        printf("%d\n",cnt);
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值