HDU2899 Strange fuction

Problem Description
Now, here is a fuction:
  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
 

Output
Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
 

Sample Input
 
 
2 100 200
 

Sample Output
 
 
-74.4291 -178.8534

代码:

#include <cstdio>
#include <cmath>
const double eps=1e-6;
double y;

double F(double x){
    return 6*pow(x,7)+8*pow(x,6)+7*pow(x,3)+5*x*x-y*x;
}

double f(double x){
    return 42*pow(x,6)+48*pow(x,5)+21*x*x+10*x-y;
}

int main(){
    int T;
    scanf("%d",&T);
    while(T--){
        scanf("%lf",&y);
        double left=0,right=100,mid;
        while(right-left>eps){
            mid=(left+right)/2;
            if(f(mid)>0) right=mid;
            else left=mid;
        }
        printf("%.4f\n",F(mid));
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ykycode

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值