Now, here is a fuction:
F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.
Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
Output
Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
Sample Input
2
100
200
Sample Output
-74.4291
-178.8534
[分析]
三分入门。
挺简单的就不赘述了,不懂三分的话,看一下上一篇文章就懂了。
[代码]
#include<cstdio>
#include<cmath>
const double eps = 1e-6;
double y;
double solve(double a)
{
return 6 * pow(a, 7) + 8 * pow(a, 6) + 7 * pow(a, 3) + 5 * pow(a, 2) - a*y;
//F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
}
int main()
{
int t;
scanf("%d", &t);
while (t--)
{
scanf("%lf", &y);
double low = 0, high = 100;
double mid, midmid;
while (low + eps < high)
{
mid = (low + high) / 2.0;
midmid = (mid + high) / 2.0;
double vmid = solve(mid);
double vmidmid = solve(midmid);
if (vmid < vmidmid)high = midmid;
else low = mid;
}
printf("%.4lf\n", solve(low));
}
}