题解-F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x

Problem Description
Now, here is a fuction:<br>&nbsp;&nbsp;F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 &lt;= x &lt;=100)<br>Can you find the minimum value when x is between 0 and 100.
 
Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)

Output
Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
 
Sample Input
 
 
2 100 200
 
Sample Output
 
 
-74.4291 -178.853


解题思路:

明白y是个什么鬼畜就没事了,由于高中知识忘得差不多再加上对题意始终懵懵懂懂,一直固执的认为y和f(x)是同一个值,然而y只是一个等待输入的常数,所求的是输入这个常数后,0-100的最小值;

但函数的增减性不确定啊,求导即可得,可以用三分法再对原函数进行操作,也可以直接由导数求零点,得到最小值;

(好像全是数学题,,)

AC.1-

#include<bits/stdc++.h>
using namespace std;
double F(double x,double y)
{
	return 6*pow(x,7)+8*pow(x,6)+7*pow(x,3)+5*pow(x,2)-y*x;
}
double f(double x)//易知导函数单调递增,则原函数先减后增;
{
	return 42*pow(x,6)+48*pow(x,5)+21*pow(x,2)+10*x;
}
int main()
{
	int t;
	double y,l,h,mid;
	cin>>t;
	while(t--)
	{
		cin>>y;
		l=0.0;h=100.0;
		while(h-l>1e-7)
		{
			mid=(l+h)/2;
			if(f(mid)<y) l=mid;//找到另导函数为零的点,即函数f(x)=y的点,带入原函数即为原函数的最小值;
			else h=mid;
		}
		printf(“%0.4lf\n”,F(mid,y));
)
	}
	return 0;
}

  • 3
    点赞
  • 7
    收藏
    觉得还不错? 一键收藏
  • 3
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值