hdu 3652 B-number

B-number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2266    Accepted Submission(s): 1227


Problem Description
A wqb-number, or B-number for short, is a non-negative integer whose decimal form contains the sub- string "13" and can be divided by 13. For example, 130 and 2613 are wqb-numbers, but 143 and 2639 are not. Your task is to calculate how many wqb-numbers from 1 to n for a given integer n.
 

Input
Process till EOF. In each line, there is one positive integer n(1 <= n <= 1000000000).
 

Output
Print each answer in a single line.
 

Sample Input
  
  
13 100 200 1000
 

Sample Output
  
  
1 1 2 2


求从1~n包含13且能被13整除的数的个数,判断包含13保存上一位,判断整除13保存余数。


#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

#define LL long long
int p[20];
LL dp[20][15][15][3];
LL dfs(int h,int last,int m,bool ok,bool sign){
	if(h<0) {
		if(m==0 && ok) return 1;
		return 0;
	}
	if(!sign && dp[h][last][m][ok]!=-1) return dp[h][last][m][ok];
	int end = sign?p[h]:9;
	LL ans = 0;
	for(int i=0;i<=end;i++){
		if(last==1 && i==3) ans += dfs(h-1,i,(m*10+i)%13,true,sign && i==p[h]);
		else ans += dfs(h-1,i,(m*10+i)%13,ok,sign && i==p[h]);
	}
	if(!sign) dp[h][last][m][ok] = ans;
	return ans;
}
LL solve(LL n){
	int cnt = 0;
	while(n>0){
		p[cnt++] = n%10;
		n /= 10;
	}
	return dfs(cnt-1,0,0,false,true);
}
int main(){
	LL n;
	memset(dp,-1,sizeof dp);
	while(cin >>n){
		cout << solve(n) <<endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值