HDU 5015解题报告

233 Matrix

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1169    Accepted Submission(s): 687


Problem Description
In our daily life we often use 233 to express our feelings. Actually, we may say 2333, 23333, or 233333 ... in the same meaning. And here is the question: Suppose we have a matrix called 233 matrix. In the first line, it would be 233, 2333, 23333... (it means a 0,1 = 233,a 0,2 = 2333,a 0,3 = 23333...) Besides, in 233 matrix, we got a i,j = a i-1,j +a i,j-1( i,j ≠ 0). Now you have known a 1,0,a 2,0,...,a n,0, could you tell me a n,m in the 233 matrix?
 

Input
There are multiple test cases. Please process till EOF.

For each case, the first line contains two postive integers n,m(n ≤ 10,m ≤ 10 9). The second line contains n integers, a 1,0,a 2,0,...,a n,0(0 ≤ a i,0 < 2 31).
 

Output
For each case, output a n,m mod 10000007.
 

Sample Input
  
  
1 1 1 2 2 0 0 3 7 23 47 16
 

Sample Output
  
  
234 2799 72937
Hint
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:   5177  5176  5175  5174  5173 


        这道题是之前做过的这些题里稍微简单一点的矩阵构造,写出状态转移方程的题。只是要抓住数字23333的规律,23=2*10+3,即要抓出乘10+3的特点进行构造。

            构造出以下矩阵即可:

         

         参考代码:

#include<cstdio>
#include<iostream>
#include<cstring>

using namespace std;

const int mod=10000007;
int n,m;
struct mat
{
    long long d[12][12];
} A,B,E;

mat multi(mat &a,mat &b)
{
    mat ans;
    for(int i=0; i<12; i++)
    {
        for(int j=0; j<12; j++)
        {
            ans.d[i][j]=0;
            for(int k=0; k<12; k++)
                ans.d[i][j]+=a.d[i][k]*b.d[k][j];
            ans.d[i][j]%=mod;
        }
    }
    return ans;
}

mat quickmulti(int n)
{
    if(n==0) return E;
    if(n==1) return A;
    mat p=E,q=A;
    while(n)
    {
        if(n&1)
        {
            n--;
            p=multi(p,q);
        }
        else
        {
            n>>=1;
            q=multi(q,q);
        }
    }
    return p;
}

int main()
{
    for(int i=0; i<12; i++)
        for(int j=0; j<12; j++)
        {
            A.d[i][j]=B.d[i][j]=E.d[i][j]=0;
            if(i==j) E.d[i][j]=1;
        }
    for(int i=0; i<11; i++)
        A.d[i][0]=10,A.d[i][11]=1;
    A.d[11][11]=1;
    for(int i=1; i<=10; i++)
        for(int j=1; j<=i; j++)
            A.d[i][j]=1;
    B.d[0][0]=23,B.d[11][0]=3;
    while(~scanf("%d%d",&n,&m))
    {
        for(int i=1; i<=n; i++)
            scanf("%d",&B.d[i][0]);
        mat c=quickmulti(m);
        c=multi(c,B);
        printf("%I64d\n",c.d[n][0]);
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值