Sum of Two Integers(规律题)

Sum of Two Integers(规律题)

Time Limit: 2 sec / Memory Limit: 1024 MB

Score : 100 points

Problem Statement

How many ways are there to choose two distinct positive integers totaling N, disregarding the order?

Constraints

·1≤N≤1000000
·N is an integer.

Input

Input is given from Standard Input in the following format:

N

Output

Print the answer.

Sample Input 1

4

Sample Output 1

1
There is only one way to choose two distinct integers totaling 4: to choose 1 and 3. (Choosing 3 and 1 is not considered different from this.)

Sample Input 2

999999

Sample Output 2

499999

题意:给定一个N,用2个不相等的数字相加等于N即算一种(这两个数字交换位置算一种情况)。当N为奇数时,结果为N/2,当N为偶数时,结果为N/2-1。

#include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;
int main()
{
	int N;
	scanf("%d", &N);
	if (N % 2 == 0)
		printf("%d\n", N / 2 - 1);
	else
		printf("%d\n", N / 2);
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值