Shopaholic

Shopaholic

时间限制(普通/Java):3000MS/10000MS          运行内存限制:65536KByte

描述


Lindsay is a shopaholic. Whenever there is a discount of the kind where you can buy three items and only pay for two, she goes completely mad and feels a need to buy all items in the store. You have given up on curing her for this disease, but try to limit its effect on her wallet.

You have realized that the stores coming with these offers are quite selective when it comes to which items you get for free; it is always the cheapest ones. As an example, when your friend comes to the counter with seven items, costing 400, 350, 300, 250, 200, 150, and 100 dollars, she will have to pay 1500 dollars. In this case she got a discount of 250 dollars. You realize that if she goes to the counter three times, she might get a bigger discount. E.g. if she goes with the items that costs 400, 300 and 250, she will get a discount of 250 the first round. The next round she brings the item that costs 150 giving no extra discount, but the third round she takes the last items that costs 350, 200 and 100 giving a discount of an additional 100 dollars, adding up to a total discount of 350.

Your job is to find the maximum discount Lindsay can get.

输入

The first line of input gives the number of test scenarios, 1 ≤ t ≤ 20. Each scenario consists of two lines of input. The first gives the number of items Lindsay is buying, 1 ≤ n ≤ 20000. The next line gives the prices of these items, 1 ≤ pi ≤ 20000.

输出

For each scenario, output one line giving the maximum discount Lindsay can get by selectively choosing which items she brings to the counter at the same time.

样例输入

1
6
400 100 200 350 300 250

样例输出

400


   本题题意是对买的东西进行打折活动。活动是每次买3个物品,3个中价格最低便可以免费,也就是说买3个只要支付2个的价格。问怎样能够省最多的钱。很明显是一个排序题,对输入的数据进行排序,每次取3个,并且将第3个的费用加起来便是能够节省的钱的最大值。

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

bool cmp(int x, int y)
{
    return x > y;
}

int main ()
{
    int lyh, sum, z, i, a[20005];
    scanf("%d",&lyh);
    while(lyh--)
    {
        sum = 0;
        memset(a,0,sizeof(a));
        scanf("%d",&z);
        for(i = 0; i < z; ++i)
            scanf("%d",&a[i]);
        sort(a, a+z, cmp); ///对价格从大到小排序
        for(i = 2; i < z; i += 3) ///每3个一取,取第3个免费的价格求和
            sum += a[i];
        printf("%d\n",sum);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值