POJ 3270 - Cow Sorting【置换群】

Cow Sorting
Time Limit: 2000MS  Memory Limit: 65536KB
Description:
Farmer John's N (1 ≤ N ≤ 10,000) cows are lined up to be milked in the evening. Each cow has a unique "grumpiness" level in the range 1...100,000. Since grumpy cows are more likely to damage FJ's milking equipment, FJ would like to reorder the cows in line so they are lined up in increasing order of grumpiness. During this process, the places of any two cows (not necessarily adjacent) can be interchanged. Since grumpy cows are harder to move, it takes FJ a total of X+Y units of time to exchange two cows whose grumpiness levels are X and Y.

Please help FJ calculate the minimal time required to reorder the cows.

Input:
Line 1: A single integer: N. 
Lines 2.. N+1: Each line contains a single integer: line i+1 describes the grumpiness of cow i. 
Output
Line 1: A single line with the minimal time required to reorder the cows in increasing order of grumpiness.

Sample Input:
3
2
3
1

Sample Output:
7


Hint:
2 3 1 : Initial order. 
2 1 3 : After interchanging cows with grumpiness 3 and 1 (time=1+3=4). 
1 2 3 : After interchanging cows with grumpiness 1 and 2 (time=2+1=3).


#include <stdio.h>
#include <iostream>
#include <string.h>
#include <algorithm>
#include <math.h>
using namespace std;
const int Max = 10010;
int a[Max], sum, mins;

struct Cow
{
    int num;
    int sub;
}cow[Max];

bool cmp(Cow a, Cow b)
{
    return a.num < b.num;
}

int solve(int n)
{
    int mem, ans = 0;
    for(int i = 1; i <= n; i++)
    {
        if(a[i] != 0)
        {
            int counts = 1;
            int id = cow[i].sub;
            mem = a[i];
            if(a[id] < mem)
                mem = a[id];
            while(id != i)///找出循环节长度
            {
                counts++;
                id = cow[id].sub;
                if(a[id] < mem)///找出循环节中最小值mem
                    mem = a[id];
            }
            a[i] = 0;
            int sum1 = (counts - 2) * mem;///循环节最小值与循环节中元素交换
            int sum2 = mem + (counts + 1) * mins;///数列中最小值与循环节中最小值交换后,再依次与循环节中元素交换
            ans += sum1 < sum2 ? sum1 : sum2;
        }
    }
    return ans;
}


int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        sum = 0;
        mins = 100000;
        for(int i = 1; i <= n; i++)
        {
            scanf("%d",&a[i]);
            sum += a[i];
            cow[i].num = a[i];
            cow[i].sub = i;
            if(mins > a[i])///找出数列中最小一个
                mins = a[i];
        }
        sort(cow+1,cow+1+n,cmp);
        printf("%d\n",solve(n)+sum);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值