UVA 10733 - The Colored Cubes【Polya定理】

The Colored Cubes
Time Limit: 3000MSMemory Limit: Unknown
      All 6 sides of a cube are to be coated with paint. Each side is is coated uniformly with one color. When a selection of n different colors of paint is available, how many different cubes can you make?
     Note that any two cubes are only to be called “different” if it is not possible to rotate the one into 
such a position that it appears with the same coloring as the other.

Input:
Each line of the input file contains a single integer n (0 < n < 1000) denoting the number of different colors. Input is terminated by a line where the value of n = 0. This line should not be processed.

Output:
For each line of input produce one line of output. This line should contain the number of differentcubes that can be made by using the according number of colors.

Sample Input:
1
2
0

Sample Output:
1
10


#include <iostream>
#include <stdio.h>
#include <string>
#include <math.h>
#include <string.h>
using namespace std;
typedef long long ll;
int n;

ll solve(int z)
{
    ll ans = 1;
    for(int i = 0; i < z; i++)
        ans *= n;
    return ans;
}

ll polya()
{
    ll sum = 0;
    sum += solve(6) + (2 * 3 * solve(3) + 3 * solve(4)) + 2 * 4 * solve(2) + 2 * 3 * solve(3);
    return sum;
}

int main()
{
    while(~scanf("%d",&n))
    {
        if(n == 0)
            break;
        printf("%lld\n",polya()/24);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值