POJ 1320 Ones(普通的DP)

Problem Description

Given a positive integer N (0<=N<=10000), you are to find an expression equals to N using only 1,+,*,(,). 1 should not appear continuously, i.e. 11+1 is not allowed.

 Input

There are multiple test cases. Each case contains only one line containing a integer N

 Output

For each case, output the minimal number of 1s you need to get N.

 Sample Input

2

10

 Sample Output

2

7

题意:给你一个数n,要你求出这个数最少由给定的格式1组成!

思路:直接DP推方程了!dp[i]=min(dp[i],dp[j]+[i/j]+dp[i%j])

所以AC代码:

 

#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;

const int maxn=10000+10;
int dp[maxn];

void init()
{
    for(int i=1;i<maxn;i++)
    {
        dp[i]=i;
        for(int j=1;j*j<=i;j++)
        {
            dp[i]=min(dp[i],dp[j]+dp[i/j]+dp[i%j]);
        }
    }
}

int main()
{
    int n;
    init();
    while(scanf("%d",&n)!=EOF)
    {
        printf("%d\n",dp[n]);
    }
    return 0;
}

 

 

 

 

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值