时间限制:10000ms
单点时限:1000ms
内存限制:256MB
给出一棵二叉树的前序和中序遍历的结果,还原这棵二叉树并输出其后序遍历的结果。
提示:分而治之——化大为小,化小为无
输入
每个测试点(输入文件)有且仅有一组测试数据。
每组测试数据的第一行为一个由大写英文字母组成的字符串,表示该二叉树的前序遍历的结果。
每组测试数据的第二行为一个由大写英文字母组成的字符串,表示该二叉树的中序遍历的结果。
对于100%的数据,满足二叉树的节点数小于等于26。
输出
对于每组测试数据,输出一个由大写英文字母组成的字符串,表示还原出的二叉树的后序遍历的结果。
样例输入
AB
BA
样例输出
BA
#include "iostream"
#include "string"
#include "algorithm"
#include "vector"
using namespace std;
string post;
void post_order(string pre, string in)
{
if(pre.length() == 0 || in.length() == 0)
return;
char root = pre[0]; //找到根结点
int pos = in.find(root, 0); //找到根节点在中序遍历中的位置
int len1 = pos; //中序pos左半部分长度
int len2 = pre.length() - pos - 1; //中序pos右半部分长度
post_order(pre.substr(1, len1), in.substr(0, len1)); //post_order(前序位置1开始的len1长度部分,中序pos位置的左半部分)
post_order(pre.substr(len1+1, len2), in.substr(pos+1, len2)); //post_order(前序位置len1开始右半部分,中序pos位置的右半部分)
cout << root;
}
int main()
{
string pre, in;
cin >> pre >> in;
post_order(pre, in);
return 0;
}