HDU1238:Substrings(暴力枚举)

Problem Description
You are given a number of case-sensitive strings of alphabetic characters, find the largest string X, such that either X, or its inverse can be found as a substring of any of the given strings.
 

Input
The first line of the input file contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case contains a single integer n (1 <= n <= 100), the number of given strings, followed by n lines, each representing one string of minimum length 1 and maximum length 100. There is no extra white space before and after a string. 
 

Output
There should be one line per test case containing the length of the largest string found.
 

Sample Input
  
  
2 3 ABCD BCDFF BRCD 2 rose orchid
 

Sample Output
  
  
2 2
 

寻找最长公共连续子串
找出最小串,然后枚举其他串,数据量不大,暴力可破
貌似KMP也能破?且会更好?

#include<stdio.h>
#include<string>

int main()
{
//freopen("in.txt","r",stdin);
//freopen("out.txt","w",stdout);
	int t,n,len,tem,MAX,MIN;
	int i,j,k;
	char str[105][105],s1[105],s2[105];
	scanf("%d",&t);
	while(t--)
	{
		MIN=1000;
		scanf("%d",&n);
		for(i=0;i<n;++i)
		{
			scanf("%s",str[i]);
			len=strlen(str[i]);
			if(MIN>len)
			{
				MIN=len;
				tem=i;
			}
		}
		int flag=1;
		MAX=0;
		for(i=0;i<MIN;++i)//控制子串的头
			for(j=i;j<MIN;++j)//控制子串的尾 
			{
				for(k=i;k<=j;++k)//复制为两个串,顺序串s1,逆序串s2  
				{
					s1[k-i]=str[tem][k];//从下标为0开始复制,实现顺序串,例如A→B→C
					s2[j-k]=str[tem][k];//从最后的下标开始复制,实现逆序串,例如C←B←A
				}
				s1[j-i+1]=s2[j-i+1]='\0';
	
				int l=strlen(s1);
				for(k=0;k<n;k++)//枚举所有串  
				{
					if(!strstr(str[k],s1)&&!strstr(str[k],s2)) {flag=0;break;}
				}
				if(l>MAX&&flag)
					MAX=l;
				flag=1;
			}
			printf("%d\n",MAX);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值