HDU:1317 XYZZY(SPFA处理正环+Flody判断点连通)

Problem Description
It has recently been discovered how to run open-source software on the Y-Crate gaming device. A number of enterprising designers have developed Advent-style games for deployment on the Y-Crate. Your job is to test a number of these designs to see which are winnable.
Each game consists of a set of up to 100 rooms. One of the rooms is the start and one of the rooms is the finish. Each room has an energy value between -100 and +100. One-way doorways interconnect pairs of rooms.

The player begins in the start room with 100 energy points. She may pass through any doorway that connects the room she is in to another room, thus entering the other room. The energy value of this room is added to the player's energy. This process continues until she wins by entering the finish room or dies by running out of energy (or quits in frustration). During her adventure the player may enter the same room several times, receiving its energy each time.

Input
The input consists of several test cases. Each test case begins with n, the number of rooms. The rooms are numbered from 1 (the start room) to n (the finish room). Input for the n rooms follows. The input for each room consists of one or more lines containing:

the energy value for room i
the number of doorways leaving room i
a list of the rooms that are reachable by the doorways leaving room i
The start and finish rooms will always have enery level 0. A line containing -1 follows the last test case.

Output
In one line for each case, output "winnable" if it is possible for the player to win, otherwise output "hopeless".

Sample Input
  
  
5 0 1 2 -60 1 3 -60 1 4 20 1 5 0 0 5 0 1 2 20 1 3 -60 1 4 -60 1 5 0 0 5 0 1 2 21 1 3 -60 1 4 -60 1 5 0 0 5 0 1 2 20 2 1 3 -60 1 4 -60 1 5 0 0 -1

Sample Output
  
  
hopeless hopeless winnable winnable
#include<stdio.h>
#include<queue>
using namespace std;
int n;
int wei[110],pw[110],cnt[110];
bool map[110][110];
bool reach[110][110];
void Floyd()
{
	for(int k=1;k<=n;k++)
		for(int i=1;i<=n;i++)
			for(int j=1;j<=n;j++)
				reach[i][j]=(reach[i][j]||(reach[i][k]&&reach[k][j]));
}
bool SPFA(int now)
{
	queue<int>Q;
	Q.push(now);
	memset(pw,0,sizeof(pw));
	memset(cnt,0,sizeof(cnt));
	pw[1]=100;
	while(!Q.empty())
	{
		int now=Q.front();
		Q.pop();
		cnt[now]++;
		if(cnt[now]>=n)
			return reach[now][n];
		for(int next=1;next<=n;next++)
			if(map[now][next]&&pw[now]+wei[next]>pw[next]&&pw[now]+wei[next]>0)
			{
				Q.push(next);
				pw[next]=pw[now]+wei[next];
			}
	}
	return pw[n]>0;
}
int main()
{
	while(~scanf("%d",&n),n>0)
	{
		memset(map,false,sizeof(map));
		memset(reach,false,sizeof(reach));
		for(int i=1;i<=n;i++)
		{
			int num;
			scanf("%d%d",&wei[i],&num);
			for(int j=1;j<=num;j++)
			{
				int k;
				scanf("%d",&k);
				map[i][k]=reach[i][k]=true;
			}
		}
		Floyd();
		if(!reach[1][n])
			puts("hopeless");
		else
		{
			if(SPFA(1))
				puts("winnable");
			else
				puts("hopeless");
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值