POJ2676:Sudoku(DFS)

Description

Sudoku is a very simple task. A square table with 9 rows and 9 columns is divided to 9 smaller squares 3x3 as shown on the Figure. In some of the cells are written decimal digits from 1 to 9. The other cells are empty. The goal is to fill the empty cells with decimal digits from 1 to 9, one digit per cell, in such way that in each row, in each column and in each marked 3x3 subsquare, all the digits from 1 to 9 to appear. Write a program to solve a given Sudoku-task. 

Input

The input data will start with the number of the test cases. For each test case, 9 lines follow, corresponding to the rows of the table. On each line a string of exactly 9 decimal digits is given, corresponding to the cells in this line. If a cell is empty it is represented by 0.

Output

For each test case your program should print the solution in the same format as the input data. The empty cells have to be filled according to the rules. If solutions is not unique, then the program may print any one of them.

Sample Input

1
103000509
002109400
000704000
300502006
060000050
700803004
000401000
009205800
804000107

Sample Output

143628579
572139468
986754231
391542786
468917352
725863914
237481695
619275843
854396127
 
 
前后用零散的时间想了两天,暴力DFS了半天,终于给我AC过了
 
 
我现在好兴奋♂
好了,正题,其实也就是行、列、宫里没有重复的数
我用三个布尔型的二维数组分别保存上面三种数据,
第一维表示序号,第二维保存数1~9,到这些数中的某个数被使用就是其为true
 
大概思路就是这样,下面说一下剪枝。
一开始我直接遍历数独的每一个格子,然后,毫无疑问肯定会TLE
后面突然想到,只需把为零的格子全部先保存,然后一个一个遍历就行了
 
#include <stdio.h>
#include <algorithm>
using namespace std;
int map[10][10];
bool cols[9][10], rows[9][10], grid[9][10];
int sign;

struct{
	int x, y;
}zero[100];

void dfs(int total)
{
	if (sign)
		return;
	if (!total)
	{
			for (int m = 0; m < 9; m++)
			{
				for (int n = 0; n < 9; n++)
					printf("%d", map[m][n]);
				printf("\n");
			}
			sign = 1;
			return;
	}
	int x = zero[total-1].x, y = zero[total-1].y;
	int pos = x / 3*3+ y / 3;
	if (map[x][y])
	{
		dfs(total);
		return;
	}
	for (int i = 1; i <= 9; i++)
	{
			if (!rows[x][i] && !cols[y][i] && !grid[pos][i])
			{
				rows[x][i] = true;
				cols[y][i] = true;
				grid[pos][i] = true;
				map[x][y] = i;
				dfs(total-1);
				map[x][y] = 0;
				rows[x][i] = false;
				cols[y][i] = false;
				grid[pos][i] = false;
			}
	}
	return;
}

int main()
{
	int t;
	char str[10];
	scanf("%d", &t);
	while (t--)
	{
		int sum= 0;
		sign = 0;
		memset(cols, 0, sizeof(cols));
		memset(rows, 0, sizeof(rows));
		memset(grid, 0, sizeof(grid));
		for (int i = 0; i < 9; i++)
		{
				scanf("%s",str);
				for (int j = 0; j < 9; j++)
				{
					map[i][j] = str[j] - '0';
					if (map[i][j] != 0)
					{
						rows[i][map[i][j]] = true;
						cols[j][map[i][j]] = true;
						int pos = j / 3 + i / 3 * 3;
						grid[pos][map[i][j]] = true;
					}
					else
					{
						zero[sum].x = i;
						zero[sum++].y = j;
					}
				}
		}
		dfs(sum);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值