POJ-2456 Aggressive cows

Aggressive cows
Time Limit: 1000MS Memory Limit: 65536K
Description
Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000). 

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

* Line 1: Two space-separated integers: N and C 

* Lines 2..N+1: Line i+1 contains an integer stall location, xi

Output

* Line 1: One integer: the largest minimum distance

Sample Input

5 3
1
2
8
4
9

Sample Output

3

Hint

OUTPUT DETAILS: 

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3. 

Huge input data,scanf is recommended.
————————————————————二分的分割线————————————————————
思路:二分逼近的模板题。二分法是一种思想。对答案进行二分的时候,意味着你在解决问题之前,事先知道了答案的区间。或者比答案大一些的区间。二分查找模板如下:
int binSearch(int a[], int l, int r, int key){
    int mid;
    while(l <= r){
        mid = (l+r) >> 1;
        if(a[mid] == key)
            return mid;
        else if(a[mid] < key)
            l = mid + 1;
        else
            r = mid - 1;
    }
    return -1;
}

要灵活运用二分的思想,不只是二分查找的模板所能解决的。本题要求“最大的最小值”,即在可行范围内尽量使牛之间的距离远,最小的答案是1,最大的答案绝不会超过Max(a[i])。考虑Check函数怎么写。既然二分的是答案(距离),那么check的时候枚举下标。一个接一个考查 当前cow下标 + m > 下一cow下标? 超过的话,该下标不能放牛。能放的话,cnt++,更新当前cow下标。
代码如下:
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <math.h>
void scanf_(int &num){ //输入外挂
    char in;
    bool neg = false;
    while(((in = getchar()) > '9'||in < '0')&&in != '-') ;
    if(in == '-') {
        neg = true;
        while((in = getchar()) >'9'||in < '0') ;
    }
    num = in - '0';
    while(in = getchar(), in >= '0'&&in <= '9')  num *= 10, num += in - '0';
    if(neg) num = 0 - num;
}
int a[100010];
int n, c;
int cmp(const void* a, const void* b) {
    return *(int *)a - *(int *)b;
}
bool check(int m) {
    int cnt = 1;//数牛
    int last = a[0];//第一头牛
    for(int i = 1; i < n; i++) {
        if(last + m > a[i]) continue;//找到满足该解的a[i]
        else {
            last = a[i];//从a[i]开始看下一头牛
            cnt++;//又放了一头牛
            if(cnt == c)    return true;//直到牛全部放完或者放不完
        }
    }
    return false;
}
int main() {
    int l = 1, r = -1;
    scanf("%d%d", &n, &c);
    for(int i = 0; i < n; i++) {
        scanf_(a[i]);
        if(r < a[i])    r = a[i];
    }
    qsort(a, n, sizeof(a[0]), cmp); //建立“下”标轴
    int mid;
    int ans = -1;
    while(l <= r) {
        mid = (l+r) >> 1;
        if(check(mid))  l = mid + 1;
        else            r = mid - 1;
    }
    printf("%d\n", r);
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值