openjudge-2456

描述

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000).

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

输入

* Line 1: Two space-separated integers: N and C

* Lines 2..N+1: Line i+1 contains an integer stall location, xi

输出

* Line 1: One integer: the largest minimum distance

样例输入

5 3
1
2
8
4
9

样例输出

3

提示

OUTPUT DETAILS:

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3.

Huge input data,scanf is recommended.

来源

USACO 2005 February Gold

想法:当奶牛的间距满足要求的时候,就要作死去尝试更加危险的组合,也就是更大的间距,当这个间距大到不能放下所有奶牛的时候,就要尝试更加安全的组合,所以当check成功的时候,低位要变成中位,check失败的时候,高位要变成中位。

 

#include <iostream>
#include<cstring>
#include<cstdlib>
#include<algorithm>

using namespace std;
int stalls, cows;
int zz[100000];
bool check(int d)
{
    int p = 0, cow = 1;
    for(int i=1;i<stalls;i++){      //验证所有的奶牛能否放入栅栏,如果能够全部放入,则返回true,如果不能放入,则返回false
        if(zz[p]+d<=zz[i]){
            cow++;
            p = i;
        }
    }
    if(cow>=cows){ return true;}
    else{return false;}
}
int main()
{
    memset(zz,0,sizeof(zz));        
    cin>>stalls>>cows;      
    for(int i=0;i<stalls;i++)   
        cin>>zz[i];
    sort(zz,zz+stalls);     //按照栅栏位置进行排序
    int left = 1, right = zz[stalls-1]-zz[0];   //低位是1,高位为最远的位置减去最近的位置
    int save = -1;      //保存位,保存最合适的中间位
    while(left<=right){

        int mid = left+(right-left)/2;          //使用这种算法可以有效避免越界
        if(check(mid)){
            left = mid+1;
            if(save<mid)
                save = mid;
        }
        else{
            right = mid-1;
        }
    }
    cout<<save<<endl;
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值