IP Address

                            IP Address

Description 
Suppose you are reading byte streams from any device, representing IP addresses. Your task is to convert a 32 characters long sequence of '1s' and '0s' (bits) to a dotted decimal format. A dotted decimal format for an IP address is form by grouping 8 bits at a time and converting the binary representation to decimal representation. Any 8 bits is a valid part of an IP address.
To convert binary numbers to decimal numbers remember that both are positional numerical systems, where the first 8 positions of the binary systems are:
2^7 2^6 2^5 2^4 2^3 2^2 2^1 2^0
128 64 32 16 8 4 2 1

Input 
The input will have a number N (1<=N<=9) in its first line representing the number of streams to convert. N lines will follow.

Output 
The output must have N lines with a doted decimal IP address. A dotted decimal IP address is formed by grouping 8 bit at the time and converting the binary representation to decimal representation.

Sample Input 
4
00000000000000000000000000000000
00000011100000001111111111111111
11001011100001001110010110000000
01010000000100000000000000000001

Sample Output 
0.0.0.0
3.128.255.255
203.132.229.128
80.16.0.1


这道题美其名曰IP地址转换其实就是进制转换,就是给你一串二进制字符串让你转换成IP地址格式输出,没啥技巧也没啥注意点直接上代码吧

#include <iostream>
#include <string>
#include <cmath>
using namespace std;

int binToDec(string s)//二进制转换成10进制
{
    int sum = 0;
    for(size_t i = 0; i < s.length(); ++i)
    {
        sum += (s[i] - '0') * pow(2,s.length()-i-1);
    }
    return sum;
}

int main()
{
    int num;
    cin >> num;
    string str,ip;
    while(num--)
    {
        cin >> str;
        int a[4] = {0};//存储转换后的数字
        int j = 0;
        for(int i = 0; i < 32; i+=8)
        {
            string sub = str.substr(i,8);//IP地址8位二进制位一段
            a[j++] = binToDec(sub);
        }
        for(int i = 0; i < 4; ++i)
        {
            cout << a[i];
            if(i != 3)//输出点
            {
                cout << '.';
            }
        }
        cout << endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值