Let the Balloon Rise

Let the Balloon Rise
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 164684 Accepted Submission(s): 65568

Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges’ favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) – the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input
5
green
red
blue
red
red
3
pink
orange
pink
0

Sample Output
red
pink
解题思路:这题我们只需要将出现的样式和频率记录下来就可以,大部分友友会选择把颜色的出现的情况先存入一个数组,这样会导致程序的局限性,我们只需要将出现的颜色记录下来并和之前出现的颜色进行比较,然后计数就可以了,代码如下:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std; 
int t;                      //气球的个数
char map[10001][20];          //存储气球的颜色;
int sum[10001];               //每个气球的颜色对应一个sum[]记录频率,并且气球编号由气球出现的顺序决定
int main()
{
    while(scanf("%d",&t)&&t)
    {
        memset(sum,0,sizeof sum);      //memset函数的作用是将某一块内存中的内容全部设置为指定的值,函数的形式为void *memset(void *s, int ch, size_t n);
		                               //将s中当前位置后面的n个字节 (typedef unsigned int size_t )用 ch 替换并返回 s ;sizeof函数的作用是判断sum的大小
        int i,j;
        for(i=0;i<t;i++)
        {
            scanf("%s",map[i]);           //输入并记录气球的颜色
            for(j=0;j<i-1;j++)
            {
                if(strcmp(map[i],map[j])==0)//把这个气球的颜色和以前出现过的气球进行比较,如果颜色相同就加1;
					                      //strcmp函数:比较两个字符串是否相同,如果相同返回0
                    sum[i]=sum[i]+1;//前面的没出现一个颜色相同的,这个颜色的气球个数就加1;
            }
        }
        int s=0;
        for(i=0;i<t;i++)//进行遍历,找出出现次数最多的颜色;
        {
            if(sum[i]>s)
            {
                s=i;//标记出现次数最多的颜色是第几个气球;
            }
        }
        printf("%s\n",map[s]);//输出这个气球的颜色;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值