Problem Description
In 2100, since the sea level rise, most of the cities disappear. Though some survived cities are still connected with others, but most of them become disconnected. The government wants to build some roads to connect all of these cities again, but they don’t want to take too much money.
Input
The first line contains the number of test cases.
Each test case starts with three integers: n, m and k. n (3 <= n <=500) stands for the number of survived cities, m (0 <= m <= 25000) stands for the number of roads you can choose to connect the cities and k (0 <= k <= 100) stands for the number of still connected cities.
To make it easy, the cities are signed from 1 to n.
Then follow m lines, each contains three integers p, q and c (0 <= c <= 1000), means it takes c to connect p and q.
Then follow k lines, each line starts with an integer t (2 <= t <= n) stands for the number of this connected cities. Then t integers follow stands for the id of these cities.
Each test case starts with three integers: n, m and k. n (3 <= n <=500) stands for the number of survived cities, m (0 <= m <= 25000) stands for the number of roads you can choose to connect the cities and k (0 <= k <= 100) stands for the number of still connected cities.
To make it easy, the cities are signed from 1 to n.
Then follow m lines, each contains three integers p, q and c (0 <= c <= 1000), means it takes c to connect p and q.
Then follow k lines, each line starts with an integer t (2 <= t <= n) stands for the number of this connected cities. Then t integers follow stands for the id of these cities.
Output
For each case, output the least money you need to take, if it’s impossible, just output -1.
Sample Input
1 6 4 3 1 4 2 2 6 1 2 3 5 3 4 33 2 1 2 2 1 3 3 4 5 6
Sample Output
1
Author
dandelion
并不算难 ,关键在于我们要有好的思路;
如果把相连的点记为0,问题就容易多了
#include<stdio.h>
#define Max 99999999
int Map[550][550];
bool Mark[550];
int lowcost[550];
int b[550];
void prime(int n)
{
int i,j,k;
int Min;
int ans=0;
for(i=1;i<=n;i++)
{
lowcost[i]=Map[1][i];
// printf("%d\n",lowcost[i]);
Mark[i]=false;
}
Mark[1]=true;
lowcost[1]=0;
for(i=1;i<=n-1;i++)
{
Min=Max;
for(j=1;j<=n;j++)
{
if(!Mark[j]&&Min>lowcost[j])
{
k=j;
Min=lowcost[j];
// printf("%d\n",k,lowcost[k]);
}
}
if(Min==Max)
break;
//printf("%d->%d\n",k,lowcost[k]);
Mark[k]=true;
ans+=lowcost[k];
for(j=1;j<=n;j++)
{
if(!Mark[j]&&lowcost[j]>Map[k][j])
lowcost[j]=Map[k][j];
}
}
if(Min==Max)
printf("-1\n");
else
printf("%d\n",ans);
}
int main()
{
int T;
int i,j;
int n,m,k;
int t;
int x,y,z;
scanf("%d",&T);
while(T--)
{
scanf("%d%d%d",&n,&m,&k);
for(i=1;i<=n;i++)
for(j=1;j<=n;j++)
{
Map[i][j]=Max;
Map[i][i]=0;
}
for(i=1;i<=m;i++)
{
scanf("%d%d%d",&x,&y,&z);
if(Map[x][y]>z)
Map[x][y]=Map[y][x]=z;
}
for(i=1;i<=k;i++)
{
scanf("%d",&t);
for(j=1;j<=t;j++)
scanf("%d",&b[j]);
for(x=1;x<=t;x++)
for(y=1;y<=t;y++)
Map[b[x]][b[y]]=0;//关键点,
}
prime(n);
}
return 0;
}
#define Max 99999999
int Map[550][550];
bool Mark[550];
int lowcost[550];
int b[550];
void prime(int n)
{
int i,j,k;
int Min;
int ans=0;
for(i=1;i<=n;i++)
{
lowcost[i]=Map[1][i];
// printf("%d\n",lowcost[i]);
Mark[i]=false;
}
Mark[1]=true;
lowcost[1]=0;
for(i=1;i<=n-1;i++)
{
Min=Max;
for(j=1;j<=n;j++)
{
if(!Mark[j]&&Min>lowcost[j])
{
k=j;
Min=lowcost[j];
// printf("%d\n",k,lowcost[k]);
}
}
if(Min==Max)
break;
//printf("%d->%d\n",k,lowcost[k]);
Mark[k]=true;
ans+=lowcost[k];
for(j=1;j<=n;j++)
{
if(!Mark[j]&&lowcost[j]>Map[k][j])
lowcost[j]=Map[k][j];
}
}
if(Min==Max)
printf("-1\n");
else
printf("%d\n",ans);
}
int main()
{
int T;
int i,j;
int n,m,k;
int t;
int x,y,z;
scanf("%d",&T);
while(T--)
{
scanf("%d%d%d",&n,&m,&k);
for(i=1;i<=n;i++)
for(j=1;j<=n;j++)
{
Map[i][j]=Max;
Map[i][i]=0;
}
for(i=1;i<=m;i++)
{
scanf("%d%d%d",&x,&y,&z);
if(Map[x][y]>z)
Map[x][y]=Map[y][x]=z;
}
for(i=1;i<=k;i++)
{
scanf("%d",&t);
for(j=1;j<=t;j++)
scanf("%d",&b[j]);
for(x=1;x<=t;x++)
for(y=1;y<=t;y++)
Map[b[x]][b[y]]=0;//关键点,
}
prime(n);
}
return 0;
}