hdu 1394 Minimum Inversion Number 线段树

Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.

Output
For each case, output the minimum inversion number on a single line.

Sample Input
  
  
10 1 3 6 9 0 8 5 7 4 2

Sample Output
  
  
16

Author
CHEN, Gaoli

Source
想建立 一个线段树,然后查看大小 ,效率较高
#include<stdio.h>
int a[15000];
struct ele
{
    int left;
    int right;
    int sum;
} p[60000];
void build(int x,int y,int step)
{
    p[step].left=x;
    p[step].right=y;
    p[step].sum=0;
    if(x==y)
        return;
    else
    {
        int Mid=(x+y)/2;
        build(x,Mid,2*step);
        build(Mid+1,y,2*step+1);
    }
}
void update(int i,int step)
{
    if(p[step].left==i&&p[step].right==i)
        p[step].sum=1;
    else
    {
        int Mid=(p[step].left+p[step].right)/2;
        if(i<=Mid)
            update(i,2*step);
        else
            update(i,2*step+1);
        p[step].sum=p[2*step].sum+p[2*step+1].sum;
    }
}
int get(int x,int y,int step)
{
    if(p[step].left==x&&p[step].right==y)
        return p[step].sum;
    else
    {
        int Mid=(p[step].left+p[step].right)/2;
        if(y<=Mid)
            return get(x,y,2*step);
        else
        if(x>=Mid+1)
            return get(x,y,2*step+1);
        else
            return get(x,Mid,2*step)+get(Mid+1,y,2*step+1);
    }
}
int main()
{
    int n;
    int i;
    int ans;
    while(scanf("%d",&n)!=EOF)
    {
        ans=0;
        build(1,n,1);
        for(i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            if(a[i]+2<=n)
                ans+=get(a[i]+2,n,1);
         //   printf("%d\n",ans);
            update(a[i]+1,1);
        }
        int Min=ans;
        for(i=1;i<=n;i++)
        {
            ans=ans+(n-1-a[i])-a[i];
            if(ans<Min)
                Min=ans;
        }
        printf("%d\n",Min);
    }




    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值