hdu 1528 Card Game Cheater 二分图的经典应用

Problem Description
Adam and Eve play a card game using a regular deck of 52 cards. The rules are simple. The players sit on opposite sides of a table, facing each other. Each player gets k cards from the deck and, after looking at them, places the cards face down in a row on the table. Adam’s cards are numbered from 1 to k from his left, and Eve’s cards are numbered 1 to k from her right (so Eve’s i:th card is opposite Adam’s i:th card). The cards are turned face up, and points are awarded as follows (for each i ∈ {1, . . . , k}):


If Adam’s i:th card beats Eve’s i:th card, then Adam gets one point.


If Eve’s i:th card beats Adam’s i:th card, then Eve gets one point.


A card with higher value always beats a card with a lower value: a three beats a two, a four beats a three and a two, etc. An ace beats every card except (possibly) another ace.


If the two i:th cards have the same value, then the suit determines who wins: hearts beats all other suits, spades beats all suits except hearts, diamond beats only clubs, and clubs does not beat any suit.

For example, the ten of spades beats the ten of diamonds but not the Jack of clubs.

This ought to be a game of chance, but lately Eve is winning most of the time, and the reason is that she has started to use marked cards. In other words, she knows which cards Adam has on the table before he turns them face up. Using this information she orders her own cards so that she gets as many points as possible.

Your task is to, given Adam’s and Eve’s cards, determine how many points Eve will get if she plays optimally.


Input
There will be several test cases. The first line of input will contain a single positive integer N giving the number of test cases. After that line follow the test cases.

Each test case starts with a line with a single positive integer k <= 26 which is the number of cards each player gets. The next line describes the k cards Adam has placed on the table, left to right. The next line describes the k cards Eve has (but she has not yet placed them on the table). A card is described by two characters, the first one being its value (2, 3, 4, 5, 6, 7, 8 ,9, T, J, Q, K, or A), and the second one being its suit (C, D, S, or H). Cards are separated by white spaces. So if Adam’s cards are the ten of clubs, the two of hearts, and the Jack of diamonds, that could be described by the line

TC 2H JD

Output
For each test case output a single line with the number of points Eve gets if she picks the optimal way to arrange her cards on the table.


Sample Input
  
  
3 1 JD JH 2 5D TC 4C 5H 3 2H 3H 4H 2D 3D 4D

Sample Output
  
  
1 1 2

Source
可以理解 为:把小于第二行的数记为联通,则最多有多少条,就有多少point;
#include<stdio.h>
#include<string.h>
#define maxn 100
bool Map[maxn][maxn];
bool Flag[maxn];
int Mark[maxn];
int lx[maxn];
int ly[maxn];
bool Find(int x,int n)
{
    int i;
    for(i=1;i<=n;i++)
    {
        if(!Map[x][i]||Flag[i])
            continue;
        Flag[i]=true;
        if(!Mark[i]||Find(Mark[i],n))
        {
            Mark[i]=x;
            return true;
        }
    }
    return false;
}
int change(char *str)
{
    int t=0,k;
    int i;
    for(i=0;i<=1;i++)
    {
        t*=10;
        if(str[i]=='2')
            k=2;
        if(str[i]=='3')
            k=3;
        if(str[i]=='4')
            k=4;
        if(str[i]=='5')
            k=5;
        if(str[i]=='6')
            k=6;
        if(str[i]=='7')
            k=7;
        if(str[i]=='8')
            k=8;
        if(str[i]=='9')
            k=9;
        if(str[i]=='T')
            k=10;
        if(str[i]=='J')
            k=11;
        if(str[i]=='Q')
            k=12;
        if(str[i]=='K')
            k=13;
        if(str[i]=='A')
            k=14;
        if(str[i]=='H')
            k=4;
        if(str[i]=='S')
            k=3;
        if(str[i]=='D')
            k=2;
        if(str[i]=='C')
            k=1;
        t+=k;
    }
    return t;
}
int main()
{
    char str[5];
    int n,m;
    int i,j;
    scanf("%d",&n);
    while(n--)
    {
        scanf("%d",&m);
        for(i=1;i<=m;i++)
        {
            scanf("%s",str);
            lx[i]=change(str);
        }
        for(i=1;i<=m;i++)
        {
             scanf("%s",str);
            ly[i]=change(str);
        }
        for(i=1;i<=m;i++)
            for(j=1;j<=m;j++)
                if(lx[i]<ly[j])
                    Map[i][j]=true;
                else
                    Map[i][j]=false;
        int Count=0;
        memset(Mark,false,sizeof(Mark));
        for(i=1;i<=m;i++)
        {
            memset(Flag,false,sizeof(Flag));
            if(Find(i,m))
                Count++;
        }
        printf("%d\n",Count);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值