Nightmare

Problem Description

Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, 
Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 
minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area 
to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the 
next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the 
exploding time to 6 minutes.

Given the layout of the labyrinth and Ignatius' start position, please tell Ignatius whether he could get out of the labyrinth, 
if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

Here are some rules:
1. We can assume the labyrinth is a 2 array.
2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he 
could not walk on a wall, too.
3. If Ignatius get to the exit when the exploding time turns to 0, he can't get out of the labyrinth.
4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can't use the 
equipment to reset the bomb.
5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the
 labyrinth as many times as you wish.
6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain 
Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. 
T test cases follow.
Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, 
each line contains M integers. The array indicates the layout of the labyrinth.
There are five integers which indicate the different type of area in the labyrinth:
0: The area is a wall, Ignatius should not walk on it.
1: The area contains nothing, Ignatius can walk on it.
2: Ignatius' start position, Ignatius starts his escape from this position.
3: The exit of the labyrinth, Ignatius' target position.
4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.

Output

For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should
 just output -1.

Sample Input

3
3 3
2 1 1
1 1 0
1 1 3
4 8
2 1 1 0 1 1 1 0
1 0 4 1 1 0 4 1
1 0 0 0 0 0 0 1
1 1 1 4 1 1 1 3
5 8
1 2 1 1 1 1 1 4 
1 0 0 0 1 0 0 1 
1 4 1 0 1 1 0 1 
1 0 0 0 0 3 0 1 
1 1 4 1 1 1 1 1 

Sample Output

4
-1

13

<pre name="code" class="plain">/*
题意:
1.
在n×m的地图上,0表示墙,1表示空地,2表示人,3表示目的地,
4表示有定时炸弹重启器。定时炸弹的时间是6,人走一步所需要
的时间是1。每次可以上、下、左、右移动一格。当人走到4时如
果炸弹的时间不是0,可以重新设定炸弹的时间为6。如果人走到3
而炸弹的时间不为0时,成功走出。求人从2走到3的最短时间。这
个题中每个结点都是可以重复访问的,但其实,炸弹重置点不要重
复走,因为,走到炸弹重置点时时间就会被设置为最大时间,当
重新返回时时间又设成最大,但此时已走的步数肯定增加了,所以
如果存在较优解的话那么肯定在第一次到这点后就可以找到较优解,
这也是代码中剪枝的原理,只是将这种思想扩展到普通点而已,
所以采用记忆化搜。
2.
剪枝很重要,不剪就会超时
从当前点x,y走到下一个可能点的距离大于从其他途径到tx,ty的距离,
且到tx,ty点时的剩余时间大于由x,y点到tx,ty点后的剩余时间,就跳过
这是因为结点可重复访问所以本身没标记,那么当上述条件满足时,
由tx,ty开始的最优解已经求过(存在或者不存在),所以不需要再重复求了。
*/
#include<stdio.h>
#include<string.h>
#include<limits.h>
#include<math.h>
int Map[9][9], mov[4][2] = {1, 0, -1, 0, 0, 1, 0, -1};
int step[9][9], time[9][9];
int n, m, Min;
void dfs(int x, int y, int len, int cnt)
{
    if(x < 0 || y < 0 || x >= n || y >= m)return ;//坐标出范围
    if(len <= 0 || cnt >= Min) return ;//超出范围
    if(Map[x][y] == 0) return ;//墙
    if(Map[x][y] == 3)//终点
    {
        if(Min > cnt) Min = cnt;//最短路径
        return ;
    }
    if(Map[x][y] == 4)len = 6;//时间重置

    if(step[x][y] <= cnt &&  time[x][y] >= len) return ;//剪枝很重要,不剪就会超时
    step[x][y] = cnt;//存当前的步数
    time[x][y] = len;//存当前的剩余时间


    int i, nx, ny;
    for(i = 0; i < 4; i++)
    {
        nx = x + mov[i][0];
        ny = y + mov[i][1];
        dfs(nx, ny, len - 1, cnt + 1);
    }
}
int main()
{
    int  t, i, j;
    int len, cnt, dy, dx;
    while(scanf("%d", &t) != EOF)
    {


        while(t--)
        {
            scanf("%d%d", &n, &m);
            for(i = 0; i < n; i++)
            {
                for(j = 0; j < m; j++)
                {

                    time[i][j] = 0;
                    step[i][j] = INT_MAX;
                    scanf("%d", &Map[i][j]);
                    if(Map[i][j] == 2)//找到起始位置
                        dx = i, dy = j;
                }
            }

            len = 6; //时间
            cnt = 0; //步数
            Min = INT_MAX;
            dfs(dx, dy, len, cnt);
            if(Min == INT_MAX)
                printf("-1\n");
            else printf("%d\n", Min);
        }
    }
    return 0;
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值