Min Number

Now you are given one non-negative integer n in 10-base notation, it will only contain digits ('0'-'9'). You are allowed to choose 2 integers i and j, such that: i!=j, 1≤i<j≤|n|, here |n| means the length of n’s 10-base notation. Then we can swap n[i] and n[j].

For example, n=9012, we choose i=1, j=3, then we swap n[1] and n[3], then we get 1092, which is smaller than the original n.

Now you are allowed to operate at most M times, so what is the smallest number you can get after the operation(s)?

Please note that in this problem, leading zero is not allowed!

Input

The first line of the input contains an integer T (T≤100), indicating the number of test cases.

Then T cases, for any case, only 2 integers n and M (0≤n<10^1000, 0≤M≤100) in a single line.

Output

For each test case, output the minimum number we can get after no more than M operations.

Sample Input

3
9012 0
9012 1
9012 2

Sample Output

9012
1092
1029

题意:

输入一个数,和n操作步数

交换n次操作步数,使这个数尽可能的变小

注意:第一个数字不能为0


#include<stdio.h>
#include<string.h>
int main()
{
int i,j,t,n,mini,x,len;
char str[1004],min;
while(scanf("%d",&t)!=EOF)
{
  getchar();
  while(t--)
  {
   scanf("%s%d",str,&n);
   len=strlen(str);         
   for(i=0;i<len;i++)
    {
      if(n==0) break;
      min=str[i];x=mini=i;
      for(j=i+1;j<len;j++)               
       {
         if(i==0)//考虑第一个不为0 
          {
            if(min>str[j]&&str[j]!='0') {mini=j;min=str[j];}       
          }                                
         else if(min>str[j]){mini=j;min=str[j];}
       }   
       int k;             
       if(mini!=x) {k=str[mini];str[mini]=str[x];str[x]=k;n--;}
    }          
    printf("%s\n",str);
  }                          
}    
return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值