C++结构体之统计最高最低分

/*
*Copyright (c) 2014 ,烟台大学计算机学院
*All rights reserved.
*作者:张凤宁
*完成日期:2014年8月4
*版本号:v1.0
*问题描述:
*样例输入:
*样例输出:
*问题分析:用简单的方法,学会活学活用
*/
#include <iostream>
using namespace std;
struct Student
{
    char name[20];
    double score;
};
int main()
{
    Student stu[5];
    Student a;
    for(int i=0; i<5; i++)
    {
        cin>>stu[i].name>>stu[i].score;
    }
    for(int j=0; j<4; j++)
    {
        for(int k=0; k<4-j; k++)
        {
            if(stu[k].score>stu[k+1].score)
            {
                a=stu[k];
                stu[k]=stu[k+1];
                stu[k+1]=a;
            }
        }
    }
    cout<<"MAX:  "<<stu[4].name<<"  "<<stu[4].score<<endl;
    cout<<endl;
    cout<<"MIN:"<<stu[0].name<<" "<<stu[0].score<<endl;
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值