输入学生成绩,输出学生成绩

/* Copyright (c) 2013, 烟台大学计算机与控制工程学院
* All rights reserved.
* 作    者: 孔令玺
* 完成日期:年 月 日
* 版 本 号:v1.0
* 问题描述:编写一个函数print,打印一个学生的成绩数组,该数组中有五个学生的数据,每个学生的成绩包括num学号,name姓名,score成绩(3门课的成绩)用主函数输入这些数据,用print函数输出这些数据* 样例输入:略
* 样例输出:略
* 问题分析:略
* 问题总结:略
* 授课教师:贺利坚
*/
/*下面是我的算法设计*/
#include <iostream>
#include <iomanip>
using namespace std;
const int n=5;
struct student
{
    char num[6];
    char name[8];
    int score[4];
}stu[n];
int main()
{
    void print(student stu[]);
    int i,j;
    for(i=0;i<n;i++)
    {
        cout<<"input scores of student"<<i+1<<":"<<endl;
        cout<<"NO.:";
        cin>>stu[i].num;
        cout<<"name:";
        cin>>stu[i].name;
        for(j=0;j<3;j++)
        {
            cout<<"score"<<j+1<<":";
            cin>>stu[i].score[j];
        }
        cout<<endl;
    }
    print (stu);
    return 0;
}
void print(student stu[])
{
    int i,j;
    cout<<"NO.       name    score1  score2  score3"<<endl;
    for(i=0;i<n;i++)
    {
        cout<<stu[i].num<<"  "<<setw(10)<<stu[i].name<<"   ";
        for(j=0;j<3;j++)
        {
            cout<<setw(3)<<stu[i].score[j]<<"   ";
        }
      cout<<endl;
    }
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值