HDOJ Text Reverse(Java)

18 篇文章 0 订阅
17 篇文章 0 订阅

Text Reverse

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15806    Accepted Submission(s): 5973


Problem Description
Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.
 

Output
For each test case, you should output the text which is processed.
 

Sample Input
  
  
3 olleh !dlrow m'I morf .udh I ekil .mca
 

Sample Output
  
  
hello world! I'm from hdu. I like acm.
Hint
Remember to use getchar() to read '\n' after the interger T, then you may use gets() to read a line and process it.
代码1:用栈实现,但是提交上去总是出现输出格式错误,不知道哪里错了,望大侠指点!!
package com.ACM1;

import java.util.Scanner;
import java.util.Stack;

public class TextReverse {

	public static void main(String[] args) {
		
		Scanner in = new Scanner(System.in);
		int t = in.nextInt();
		in.nextLine();
		while(t-- > 0){
			String str = in.nextLine();
			String[] words = str.split(" ");
			String strReverse = "";
			for(int i=0; i<words.length; i++){
				
				String word = words[i];
				Stack<Character> stack = new Stack<Character> ();
				for(int j=0; j<word.length(); j++){
					
					stack.add(word.charAt(j));
					
				}
				
				while(!stack.isEmpty()){
					strReverse += stack.pop();
				}
				if(i != words.length-1){
					strReverse += " ";
				}
			}
			
			System.out.println(strReverse);
			
			
			
		}
		
		
		
	}

}

借鉴了下别人的AC代码:依次遍历每个字符,遇到空格或已到字符串末尾反向输出保存的字符,记得每次输出一串字符要换行.
import java.util.Scanner;

public class Main {

    public static void main(String[] args) {
        
        Scanner in = new Scanner(System.in);
        int t = in.nextInt();
        in.nextLine();
        while(t-- > 0){
            
            String str = in.nextLine();
            int length = str.length();
            char[] c = new char[length];
            int k = 0;
            for(int i=0; i<=length; i++){
                if( i == length || str.charAt(i) == ' '){
                    
                    for(; k>0; k--){
                        System.out.print(c[k-1]);
                    }
                    
                    if(i<length){
                        System.out.print(str.charAt(i));
                    }
                    
                }else{
                    c[k++] = str.charAt(i);
                }
            }
            System.out.println();
            
        }

    }

}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值