poj1731 Orders dfs

Orders
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 9709 Accepted: 5929
Description

The stores manager has sorted all kinds of goods in an alphabetical order of their labels. All the kinds having labels starting with the same letter are stored in the same warehouse (i.e. in the same building) labelled with this letter. During the day the stores manager receives and books the orders of goods which are to be delivered from the store. Each order requires only one kind of goods. The stores manager processes the requests in the order of their booking.

You know in advance all the orders which will have to be processed by the stores manager today, but you do not know their booking order. Compute all possible ways of the visits of warehouses for the stores manager to settle all the demands piece after piece during the day.
Input

Input contains a single line with all labels of the requested goods (in random order). Each kind of goods is represented by the starting letter of its label. Only small letters of the English alphabet are used. The number of orders doesn’t exceed 200.
Output

Output will contain all possible orderings in which the stores manager may visit his warehouses. Every warehouse is represented by a single small letter of the English alphabet – the starting letter of the label of the goods. Each ordering of warehouses is written in the output file only once on a separate line and all the lines containing orderings have to be sorted in an alphabetical order (see the example). No output will exceed 2 megabytes.
Sample Input

bbjd
Sample Output

bbdj
bbjd
bdbj
bdjb
bjbd
bjdb
dbbj
dbjb
djbb
jbbd
jbdb
jdbb
Source

CEOI 1999

题目的意思是用输入的语句用alphabetical(按字母表排序,也就是从a到z)的方式,进行全排列。将所有可能的情况输出来,每个字母不能重复使用。

这个题有两种方法可以解决。
第一种比较简单,用C++的algorithm头文件里的next_permutation(ch,ch+strlen(ch))一用上就解决了。
这是函数所用的内存和时间

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
int main(){
    char ch[205];
    while(~scanf("%s", ch)){
        sort(ch, ch+strlen(ch));
        do{
            for(int i = 0; i < strlen(ch); i++){
                printf("%c", ch[i]);
            }
            puts("");
        }while(next_permutation(ch, ch+strlen(ch)));
    }
    return 0;
}

而第二种比较麻烦,但是时间比较短。
思路是用深搜进行遍历,同时做一个标记,避免找到相同的字符。

下面的vis数组用来记录某个字符有没有用过,
ch是题中给出的字符串,排序后就不再动了。
give是全排列得到的字符串,具体是怎么实现的我现在也不清楚,先挖个坑,以后来填。
这是dfs

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
char ch[205], give[205]; 
bool vis[205];
void dfs(int x){
    char c = '\0';
    if(x == strlen(ch)){
        give[x] = c;
        printf("%s\n", give);
    }
    for(int i = 0; i < strlen(ch); i++){
        if(!vis[i] && ch[i] != c){
            give[x] = ch[i];
            vis[i] = true;
            c = ch[i];
            dfs(x+1);
            vis[i] = false;
        }
    }
}
int main(){
    int n;
    while(scanf("%s", ch) != EOF){
        memset(vis, false, sizeof(vis));
        int l = strlen(ch);
        sort(ch, ch+strlen(ch));
        dfs(0);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值