HOJ Delta-wave

题目链接

Problem Description
A triangle field is numbered with successive integers in the way shown on the picture below.

The traveller needs to go from the cell with number M to the cell with number N. The traveller is able to enter the cell through cell edges only, he can not travel from cell to cell through vertices. The number of edges the traveller passes makes the length of the traveller’s route.

Write the program to determine the length of the shortest route connecting cells with numbers N and M.

Input
Input contains two integer numbers M and N in the range from 1 to 1000000000 separated with space(s).

Output
Output should contain the length of the shortest route.

Sample Input
6 12

Sample Output
3

这是参考链接
这是参考链接
这是参考链接

这里写图片描述
这里写图片描述
总结:主要是找规律,重点在找两个数的坐标,可以巧妙的运用坐标系。
注意取绝对值函数,abs与fabs
int abs(int i); // 处理int类型的取绝对值
double fabs(double i); //处理double类型的取绝对值
float fabsf(float i); /处理float类型的取绝对值

代码:

#include <iostream>
#include <cmath>
using namespace std;

int main(){
    int a,b;
    int aLayer,bLayer;
    int aX,aY,bX,bY;
    int distance;

    while(cin >> a >> b){
        aLayer = ceil(sqrt(a));
        bLayer = ceil(sqrt(b));

        if(aLayer == bLayer)
            distance = b - a;
        else{
            aX = (aLayer * aLayer - a) / 2;
            aY = aLayer - (aLayer * aLayer - a + 1) / 2 - 1;
            bX = (bLayer * bLayer - b) / 2;
            bY = bLayer - (bLayer * bLayer - b + 1) / 2 - 1;

            distance = abs(aX - bX) + abs(aY - bY) + abs(aLayer - bLayer);
        }

        cout << distance << endl;
    }


}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值