triangle field两点经过的区域数

A triangle field is numbered with successive integers in the way shown on the picture below. 




The traveller needs to go from the cell with number M to the cell with number N. The traveller is able to enter the cell through cell edges only, he can not travel from cell to cell through vertices. The number of edges the traveller passes makes the length of the traveller's route. 

Write the program to determine the length of the shortest route connecting cells with numbers N and M. 
Input
Input contains two integer numbers M and N in the range from 1 to 1000000000 separated with space(s).
Output
Output should contain the length of the shortest route.
Sample Input
6 12 
Sample Output
3
代码:
#include <stdio.h>

#include <math.h>

void main() {

    unsigned int m,n,ai,aj,bi,bj,ak,bk;

    while (scanf("%d%d",&m,&n)!=EOF) {

        ai = sqrt(m-1)+1;

        bi = sqrt(n-1)+1;

        aj = (m-(ai-1)*(ai-1)-1)/2+1;

        bj = (n-(bi-1)*(bi-1)-1)/2+1;

        ak = (ai*ai-m)/2+1;

        bk = (bi*bi-n)/2+1;

        printf("%d/n",abs(ai-bi)+abs(aj-bj)+abs(ak-bk));

    }

}
 题目大意:数字按照所给图形进行排列,给出两点,求两点距离。
  解题思路:图画大一点,然后找规律:固定这个数字的三维坐标,行很好找,直接将这个数开根号就可以知道是第几行,如果开根号正好是整数的话就直接是行号,否则需要加1,对于列有两个方向都需要进行求解。具体如下图:
  第一种右斜着的列号: 第二种是左斜着的列号:
  
  根据这两种进行找规律。
求三角形内两点的最短路径,题目见这里,很容易证明最短的路径就是两点在三个方向的距离之和。
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值