数学—杭电1030 Delta-wave

http://acm.hdu.edu.cn/showproblem.php?pid=1030

Delta-wave

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5272    Accepted Submission(s): 1986

Problem Description
A triangle field is numbered with successive integers in the way shown on the picture below.



The traveller needs to go from the cell with number M to the cell with number N. The traveller is able to enter the cell through cell edges only, he can not travel from cell to cell through vertices. The number of edges the traveller passes makes the length of the traveller's route.

Write the program to determine the length of the shortest route connecting cells with numbers N and M.
 
Input
Input contains two integer numbers M and N in the range from 1 to 1000000000 separated with space(s).
 
Output
Output should contain the length of the shortest route.
 
Sample Input
  
  
6 12
 
Sample Output
  
  
3

 

#include <iostream>
#include <cmath>
using namespace std;
int main()
{
    int n,m;
    int nx,ny,nz,mx,my,mz;
    while(cin>>n>>m)
    {
    nx=(int)sqrt(double(n-1))+1;
    mx=(int)sqrt(double(m-1))+1;
    ny=abs((nx-1)*(nx-1)+1-n)/2+1;
    my=abs((mx-1)*(mx-1)+1-m)/2+1;
    nz=abs(nx*nx-n)/2+1;
    mz=abs(mx*mx-m)/2+1;
    cout<<abs(nx-mx)+abs(ny-my)+abs(nz-mz)<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值