HDU 算术不同解法题:(Problem ID:1028)

HDU题址:http://acm.hdu.edu.cn/showproblem.php?pid=1028

Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
 

Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
 

Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
 

Sample Input
  
  
4 10 20
 

Sample Output
  
  
5 42 627

思路:采用动态规划(DP)的思想,牺牲空间创建一个二维表a[][],a[i][j]表示对i进行划分,最大加数为j..

    建表时,当i==j时,a[i][j]=a[i][j-1]+1,就比如对6进行划分,若j=i=6,即最大加数也是6,那么,就相当于6划分最大加数5时,再加上个1(种解),    6=6 => 6=5+1

    当i<j时, a[i][j]=a[i][i],照着前面的填表就好...因为不存在最大加数比要划分的数还大的情况,即6不可能划分出7+....

    当i>j时,和之前i==j的区别就是,当前他的最大加数不是他本身,对6划分,最大加数是4,可以分出 6=4+2 和6=4+1+1,相当于其实只用对6-4也就是2进行划                                                分就行了。所以有, a[i][j]=a[i][j-1]+a[i-j][j]....

            这样动规搞定的一张表,输出想要的就可以了。fighting~~~奋斗


AC代码:

#include<stdio.h>

#include<string.h>

 

int main()

{

         inta[121][121];//a[i][j]表示对i进行划分,最大加数为j

         int N;

         for(int i=1;i<=120;i++)

                   a[i][1]=a[1][i]=1;

         for(int i=2;i<=120;i++)

         {

                   for(int j=2;j<=120;j++)

                   {

                            if(i==j)      a[i][j]=a[i][j-1]+1;

                            if(i<j)                  a[i][j]=a[i][i];

                            if(i>j)                  a[i][j]=a[i][j-1]+a[i-j][j];

                   }

         }

         while(scanf("%d",&N)!=EOF)

         {

                   printf("%d\n",a[N][N]);

         }

         return0;


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值