HDU 1028 整数拆分 (母函数_模板|| 背包)

Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
 

Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
 

Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
 

Sample Input
  
  
4 10 20
 

Sample Output
  
  
5 42 627
 



#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=200;
int c1[maxn],c2[maxn];  //(1+x+x^2+x^3)(1+x^2)(1+x^3)
int main()
{
	int n,i,j,k;
	while(scanf("%d",&n)!=EOF) {
		for(i=0;i<=n;i++) {
			c1[i]=1;
			c2[i]=0;
		}
		for(i=2;i<=n;i++)  {     //第i个多项式 
		     for(j=0;j<=n;j++)  {     //第i-1个多项式的第j项
		         for(k=0;k+j<=n;k+=i)  {  //  第i个多项式的每个元素遍历
		             c2[j+k]+=c1[j];
			     }
     		}
     		for(j=0;j<=n;j++) {
     			c1[j]=c2[j];
     			c2[j]=0;
			 }
     	}
     	printf("%d\n",c1[n]);
	}   
	return 0;
}




用背包解决。。。  发现算法真是神奇


#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
using namespace std;
const int maxn=200;
int dp[maxn];
int main()
{
	int n,i,j;
	while(scanf("%d",&n)!=EOF) {
		memset(dp,0,sizeof(dp));
		dp[0]=1;
		for(i=1;i<=n;i++) {
			for(j=i;j<=n;j++)
			dp[j]+=dp[j-i];
		}
		printf("%d\n",dp[n]);
	}
	return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值