Edge水流向题(Problem ID:1033)

题址:http://acm.hdu.edu.cn/showproblem.php?pid=1033

Problem Description
For products that are wrapped in small packings it is necessary that the sheet of paper containing the directions for use is folded until its size becomes small enough. We assume that a sheet of paper is rectangular and only folded along lines parallel to its initially shorter edge. The act of folding along such a line, however, can be performed in two directions: either the surface on the top of the sheet is brought together, or the surface on its bottom. In both cases the two parts of the rectangle that are separated by the folding line are laid together neatly and we ignore any differences in thickness of the resulting folded sheet.
After several such folding steps have been performed we may unfold the sheet again and take a look at its longer edge holding the sheet so that it appears as a one-dimensional curve, actually a concatenation of line segments. If we move along this curve in a fixed direction we can classify every place where the sheet was folded as either type A meaning a clockwise turn or type V meaning a counter-clockwise turn. Given such a sequence of classifications, produce a drawing of the longer edge of the sheet assuming 90 degree turns at equidistant places.


Input
The input contains several test cases, each on a separate line. Each line contains a nonempty string of characters A and V describing the longer edge of the sheet. You may assume that the length of the string is less than 200. The input file terminates immediately after the last test case.


Output
For each test case generate a PostScript drawing of the edge with commands placed on separate lines. Start every drawing at the coordinates (300, 420) with the command "300 420 moveto". The first turn occurs at (310, 420) using the command "310 420 lineto". Continue with clockwise or counter-clockwise turns according to the input string, using a sequence of "x y lineto" commands with the appropriate coordinates. The turning points are separated at a distance of 10 units. Do not forget the end point of the edge and finish each test case by the commands stroke and showpage.

You may display such drawings with the gv PostScript interpreter, optionally after a conversion using the ps2ps utility.





Sample Input
V
AVV


Sample Output
300 420 moveto
310 420 lineto
310 430 lineto
stroke
showpage
300 420 moveto
310 420 lineto
310 410 lineto
320 410 lineto
320 420 lineto
stroke
showpage

流水问题,很简单的水题,输入的A代表接下来往顺时针90°走,V则是逆时针方向走。

只需要知道,上一次是什么走向,上下左右,再配合A或者V就知道它接下来怎么移动坐标了。


AC代码:

#include<stdio.h>
int main()
{
	char str[200];
	//int dir[3][2]={{10,0},{0,10},{0,-10}};
	int dir;
	while(scanf("%s",&str)!=EOF)
	{
		int i,len,xi=300,yi=420;
		char dir='y';
		printf("%d %d moveto\n",xi,yi);
		xi+=10;
		printf("%d %d lineto\n",xi,yi);
		for(i=0;str[i]!='\0';i++)
			len=i+1;
		//printf("%d\n",len);
		for(i=0;i<len;i++)
		{
			switch(dir)
			{
			case 'y':   //'y'表示之前是往右走的方向
				if(str[i]=='V') dir='s',yi+=10;
				else dir='x',yi-=10;
				break;
			case 'z':   //'z'表示之前是往左走的方向
				if(str[i]=='V') dir='x',yi-=10;
				else dir='s',yi+=10;
				break;
			case 's':   //'s'表示之前是往上走的方向
				if(str[i]=='V') dir='z',xi-=10;
				else dir='y',xi+=10;
				break;
			case 'x':   //'x'表示之前是往下走的方向
				if(str[i]=='V') dir='y',xi+=10;
				else dir='z',xi-=10;
				break;
			}
			printf("%d %d lineto\n",xi,yi);
		}
		printf("stroke\nshowpage\n");
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值