思路:
分治和贪心算法,在给定范围[begin, end]内,查找价格最低的加油站;如果没有找到,可以往前 [begin, begin-A*C]的范围内找。
1033 To Fill or Not to Fill (25 point(s))
With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may give different price. You are asked to carefully design the cheapest route to go.
Input Specification:
Each input file contains one test case. For each case, the first line contains 4 positive numbers: Cmax (≤ 100), the maximum capacity of the tank; D (≤30000), the distance between Hangzhou and the destination city; Davg (≤20), the average distance per unit gas that the car can run; and N (≤ 500), the total number of gas stations. Then N lines follow, each contains a pair of non-negative numbers: Pi, the unit gas price, and Di (≤D), the distance between this station and Hangzhou, for i=1,⋯,N. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print the cheapest price in a line, accurate up to 2 decimal places. It is assumed that the tank is empty at the beginning. If it is impossible to reach the destination, print The maximum travel distance = X
where X
is the maximum possible distance the car can run, accurate up to 2 decimal places.
Sample Input 1:
50 1300 12 8
6.00 1250
7.00 600
7.00 150
7.10 0
7.20 200
7.50 400
7.30 1000
6.85 300
Sample Output 1:
749.17
Sample Input 2:
50 1300 12 2
7.10 0
7.00 600
Sample Output 2:
The maximum travel distance = 1200.00
Example:
#include<iostream>
#include<list>
#include<map>
using namespace std;
struct Station {
double Price;
int Dist;
};
int C, D, A, N, Length;
double Price;
map<int, int> Path;
void solve(list<Station> &s, int begin, int end)
{
if(begin >= end) return ;
bool find = false;
auto x = s.begin();
for(; x != s.end(); x++) {
int temp = x->Dist;
if(temp > end) continue;
if(temp >= begin || temp >= begin-C*A) {
find = true;
break;
}
}
if(find) {
int b = max(begin, x->Dist);
int e = min(end, x->Dist+C*A);
double len = e - b;
Path[b] = e;
Length += len;
Price += len/A * x->Price;
s.erase(x);
solve(s, begin, b);
solve(s, e, end);
}
}
int main()
{
cin >> C >> D >> A >> N;
list<Station> station;
for(int i = 0; i < N; i++) {
double price;
int dist;
cin >> price >> dist;
auto x = station.begin();
for(; x != station.end(); x++)
if(price < x->Price) break;
else if(price == x->Price && dist < x->Dist) break;
station.insert(x, {price, dist});
}
Price = 0, Length = 0;
solve(station, 0, D);
if(Length == D) printf("%.2f\n", Price);
else {
int dist = 0;
while(Path.count(dist)) dist = Path[dist];
printf("The maximum travel distance = %.2f", (double)dist);
}
}