lightoj 1369 Answering Queries

                                                   Answering Queries
Time Limit:3000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu

Description

The problem you need to solve here is pretty simple. You are give a function f(A, n), where A is an array of integers and n is the number of elements in the array. f(A, n) is defined as follows:

long long f( int A[]int n ) { // n = size of A

    long long sum = 0;

    for( int i = 0; i < n; i++ )

        for( int j = i + 1; j < n; j++ )

            sum += A[i] - A[j];

    return sum;

}

Given the array A and an integer n, and some queries of the form:

1)      0 x v (0 ≤ x < n, 0 ≤ v ≤ 106), meaning that you have to change the value of A[x] to v.

2)      1, meaning that you have to find f as described above.

Input

Input starts with an integer T (≤ 5), denoting the number of test cases.

Each case starts with a line containing two integers: n and q (1 ≤ n, q ≤ 105). The next line contains n space separated integers between 0 and 106 denoting the array A as described above.

Each of the next q lines contains one query as described above.

Output

For each case, print the case number in a single line first. Then for each query-type "1" print one single line containing the value of f(A, n).

Sample Input

1

3 5

1 2 3

1

0 0 3

1

0 2 1

1

Sample Output

Case 1:

-4

0

4



根据性质,推公式   

当a[x] 改成v 时    ans 增加了  (n-1-x)*(v-a[x])+  x *(a[x] - x)  


<pre name="code" class="cpp">#include <iostream>      
#include <cstdio> 
#include <cstring>
using namespace std;
const int maxn=100005;


long long a[maxn],sum,ans,v;
int n,q,op,x;


int main()
{
    int T;
    scanf("%d",&T);
    for(int co=1;co<=T;co++)
    {
         scanf("%d %d",&n,&q);
         for(int i=0;i<n;i++)  scanf("%lld",&a[i]);
         sum=a[n-1],ans=0;
         for(int i=n-2,j=1;i>=0;i--,j++)
         {
              ans+=j*a[i]-sum;
              sum+=a[i];
         }
         printf("Case %d:\n",co);
         for(int i=0;i<q;i++)
         {
              scanf("%d",&op);
              if(op==1)  printf("%lld\n",ans);
              else
              {
                   scanf("%d %lld",&x,&v);
                   ans=ans+(n-1-x)*(v-a[x])+x*(a[x]-v);
                   a[x]=v;
              }
         }
    }
    return 0;
}


 
   

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值