Avoid The Lakes
Time Limit : 2000/1000ms (Java/Other) Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 194 Accepted Submission(s) : 108
Problem Description
Farmer John's farm was flooded in the most recent storm, a fact only aggravated by the information that his cows are deathly afraid of water. His insurance agency will only repay him, however, an amount depending on the size of the largest "lake" on his farm.
The farm is represented as a rectangular grid with N (1 ≤ N ≤ 100) rows and M (1 ≤ M ≤ 100) columns. Each cell in the grid is either dry or submerged, and exactly K (1 ≤ K ≤ N × M) of the cells are submerged. As one would expect, a lake has a central cell to which other cells connect by sharing a long edge (not a corner). Any cell that shares a long edge with the central cell or shares a long edge with any connected cell becomes a connected cell and is part of the lake.
Input
* Line 1: Three space-separated integers: N, M, and K
* Lines 2..K+1: Line i+1 describes one submerged location with two space separated integers that are its row and column: R and C
Output
* Line 1: The number of cells that the largest lake contains.
Sample Input
3 4 5
3 2
2 2
3 1
2 3
1 1
Sample Output
Time Limit : 2000/1000ms (Java/Other) Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 194 Accepted Submission(s) : 108
Problem Description
Farmer John's farm was flooded in the most recent storm, a fact only aggravated by the information that his cows are deathly afraid of water. His insurance agency will only repay him, however, an amount depending on the size of the largest "lake" on his farm.
The farm is represented as a rectangular grid with N (1 ≤ N ≤ 100) rows and M (1 ≤ M ≤ 100) columns. Each cell in the grid is either dry or submerged, and exactly K (1 ≤ K ≤ N × M) of the cells are submerged. As one would expect, a lake has a central cell to which other cells connect by sharing a long edge (not a corner). Any cell that shares a long edge with the central cell or shares a long edge with any connected cell becomes a connected cell and is part of the lake.
Input
* Line 1: Three space-separated integers: N, M, and K
* Lines 2..K+1: Line i+1 describes one submerged location with two space separated integers that are its row and column: R and C
Output
* Line 1: The number of cells that the largest lake contains.
Sample Input
3 4 5
3 2
2 2
3 1
2 3
1 1
Sample Output
4
POJ-3620
题目大意:每一个大湖都是有许多的小湖组成,问图中最大湖所包含的小湖的数目;(整块图是由N*M大的网格组成,每个小格代表一个小湖;
只有含有相同边的小湖才能构成一个整体)
解题思路:
首先,定义一个二维数组,并对所有的小湖标记为1;
然后,定义DFS函数搜索图中的每个大湖并记录其所包含小湖的数目;
每次得到的数目与max比较,如果其比max大,就将其赋给max;
#include<stdio.h>
#include<string.h>
int a[120][120];
int n,m,k,count;
int dfs(int x,int y){
if(x<1||x>n||y<1||y>m)
return ;
if(a[x][y]!=1)
return ;
count++;
a[x][y]=0;
dfs(x-1,y);
dfs(x+1,y);
dfs(x,y-1);
dfs(x,y+1);
}
int main()
{
int i,j,r,c,max;
while(scanf("%d%d%d",&n,&m,&k)!=EOF){
for(i=1;i<=k;i++){
getchar();
scanf("%d%d",&r,&c);
a[r][c]=1;}
count=0;max=-1;
for(i=1;i<=n;i++)
for(j=1;j<=m;j++)
{
dfs(i,j);
if(count>max)
max=count;
count=0;
}
memset(a,0,sizeof(a));
printf("%d\n",max);
}
return 0;
}