openjudge avoid the lakes

2405:Avoid The Lakes

总时间限制: 
20000ms 
单个测试点时间限制: 
1000ms 
内存限制: 
65536kB
描述
Farmer John's farm was flooded in the most recent storm, a fact only aggravated by the information that his cows are deathly afraid of water. His insurance agency will only repay him, however, an amount depending on the size of the largest "lake" on his farm.

The farm is represented as a rectangular grid with N (1 <= N <= 100) rows and M (1 <= M <= 100) columns. Each cell in the grid is either dry or submerged, and exactly K (1 <= K <= N*M) of the cells are submerged. As one would expect, a lake has a central cell to which other cells connect by sharing a long edge (not a corner). Any cell that shares a long edge with the central cell or shares a long edge with any connected cell becomes a connected cell and is part of the lake.
输入
* Line 1: Three space-separated integers: N, M, and K

* Lines 2..K+1: Line i+1 describes one submerged location with two space separated integers that are its row and column: R and C
输出
* Line 1: The number of cells that the largest lake contains.
样例输入
3 4 5
3 2
2 2
3 1
2 3
1 1
样例输出
4
提示
INPUT DETAILS:
The farm is a grid with three rows and four columns; five of the cells are submerged. They are located in the positions (row 3, column 2); (row 2, column 2); (row 3, column 1); (row 2, column 3); (row 1, column 1):
              # . . .
              . # # .
              # # . .

OUTPUT DETAILS:

The largest lake consists of the input's first four cells.
来源

USACO November 2007 Bronze

  

题目大意:John有一个农场被水淹了,可以获得保险公司的一些赔偿,但是是有条件的,赔偿数目取决于被淹的农场中最大的水洼大小。John的农场是个矩形,由一个个的小方格组成,输入中 N行, M列, K个被淹的方格。所以可能有多个水洼,而每个水洼可以由多个小方格构成(小方格之间必须是边连着的,不能是角相连),找出包含最多被淹的小方格的水洼。


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int map[110][110],n,m,i,j,p,ans,num;
int xx[10]={-1,0,1,0},yy[10]={0,-1,0,1};
void dfs(int x,int y)
{
for (int i=0;i<=3;i++)
{
int xl=x+xx[i],yl=y+yy[i];
if (map[xl][yl]==1&&xl>0&&xl<=n&&yl>0&&yl<=m)
{
map[xl][yl]=0;
num++;
dfs(xl,yl);
}

}
int main()
{
scanf("%d%d%d",&n,&m,&p);
for (i=1;i<=p;i++)
{
int x,y;
scanf("%d%d",&x,&y);
map[x][y]=1;
}
for (i=1;i<=n;i++)
for (j=1;j<=m;j++)
 if (map[i][j]==1)
  {
  map[i][j]=0;
  num=1;
  dfs(i,j);
  ans=max(ans,num);
  } 
printf("%d",ans);
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值