HDU 1170 Balloon Comes! 简单的四则运算

Balloon Comes!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 20600    Accepted Submission(s): 7790

Problem Description
The contest starts now! How excited it is to see balloons floating around. You, one of the best programmers in HDU, can get a very beautiful balloon if only you have solved the very very very... easy problem.
Give you an operator (+,-,*, / --denoting addition, subtraction, multiplication, division respectively) and two positive integers, your task is to output the result.
Is it very easy?
Come on, guy! PLMM will send you a beautiful Balloon right now!
Good Luck!
 
Input
Input contains multiple test cases. The first line of the input is a single integer T (0<T<1000) which is the number of test cases. T test cases follow. Each test case contains a char C (+,-,*, /) and two integers A and B(0<A,B<10000).Of course, we all know that A and B are operands and C is an operator.
 
Output
For each case, print the operation result. The result should be rounded to 2 decimal places If and only if it is not an integer.
 
Sample Input
  
  
4 + 1 2 - 1 2 * 1 2 / 1 2
 
Sample Output
  
  
3 -1 2 0.50

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1170

/*
Balloon Comes! 1170
简单的四则运算 用case 
除法时 不是整数才.2f 否则整数 
4
+ 1 2
- 1 2
* 1 2
/ 1 2 
*/

#include<iostream>
using namespace std;
int main(){
    int n,a,b,t,k;
    char c;
    cin>>n; 

    while(n--)
    {    getchar();
        scanf("%c %d %d",&c,&a,&b); 
        switch(c){
            case '+': printf("%d\n",a+b);break;
            case '-': printf("%d\n",a-b);break;
            case '*': printf("%d\n",a*b);break;
            case '/': 
                    if (a%b)  printf("%.2f\n",float(a)/b);
                        else printf("%d\n",a/b);
                    break;
        }
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值