已知前序中序,输出后序

Tree Recovery
查看 提交 统计 提问
总时间限制: 1000ms 内存限制: 65536kB
描述
Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes. 
This is an example of one of her creations: 


                                               D
                                              / \
                                             /   \
                                            B     E
                                           / \     \
                                          /   \     \
                                         A     C     G
                                                    /
                                                   /
                                                  F


To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG. 
She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it). 


Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree. 
However, doing the reconstruction by hand, soon turned out to be tedious. 
So now she asks you to write a program that does the job for her! 


输入
The input will contain one or more test cases. 
Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.)
Input is terminated by end of file. 


输出
For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).
样例输入
DBACEGF ABCDEFG
BCAD CBAD
样例输出
ACBFGED
CDAB




题目大意:
    已知树的前序和中序,求后序
思路:
前序遍历是父,左子,右子的遍历顺序,而中序是左子,父,右子的遍历顺序,前序相当与根,中序是为了找左右子树,从而遍历下去
所以只需不断找左右子树,在找完某个根的左右子树后,进行输出
前面操作完再进行进行操作,就是后需遍历,(联想归并)


也可以先建树再遍历,建树的过程还是通过根找左右子树,如果第二个根在第二个根的左子树集合中就是上一个点的2n,否则就是2n+1的位置存放的



	#include<stdio.h>
#include<string.h>
char pre[1000], in[1000];
int len, k,step;
void search(int l, int r, int i){
	int j;
	if(step 》 len){//遍历完前序了,就退出
		return ;
	}
	for(j = l; j < r; j++){//在这个区间找到该点,下一次就找前序的下一个点
		if(in[j] == pre[step]){
			step++;
			break;
		}
	}
	if(j == r){//说明这个区间没有找到该点
		return ;
	}
	search(l, j,i + 1);
	search(j + 1, r, i + 1);
	printf("%c", in[j]);


}

int main(){

	int i;
	while(scanf("%s%s", pre, in) != EOF){
		getchar();
		step = 0;
		len = strlen(pre);
		search(0, len , 0);
		printf("\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值