杭电 1042 N! 大数相乘

Problem Description
Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!
 

Input
One N in one line, process to the end of file.
 

Output
For each N, output N! in one line.
 

Sample Input
  
  
1 2 3
 

Sample Output
  
  
1 2 6 代码如下:
#include<iostream>
#include<cstring>
#include<iomanip>
using namespace std ; 
const int MAX = 9000 ;
const int UP = 10000 ; 
int main(){
	int a[MAX] ; 
	int n;
	while(cin>>n){
		for(int i=0 ; i<MAX ; ++i) a[i] = 0;
		
		
		a[0] = 1; 
		int t = 1;
		for(int i=1 ; i<=n ; ++i){
			int so  = 0 ;
			for(int j=0 ; j<t ; ++j){
				a[j] = i*a[j]+so ;
				so   = a[j]/UP ;
				a[j] = a[j]%UP ;
			}
			while(so){
				a[t++] += so%UP;
				so /= UP;
			}
		}
		
		cout<<a[--t];
		while(t > 0 )    cout<<setw(4)<<setfill('0')<<a[--t];
		cout<<endl;
	}
	
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值