poj3126_Prime Path

Prime Path
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9833 Accepted: 5648

Description

The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices.
— It is a matter of security to change such things every now and then, to keep the enemy in the dark.
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know!
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door.
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime!
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds.
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime.

Now, the minister of finance, who had been eavesdropping, intervened.
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound.
— Hmm, in that case I need a computer program to minimize the cost. You don't know some very cheap software gurus, do you?
— In fact, I do. You see, there is this programming contest going on... Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above.
1033
1733
3733
3739
3779
8779
8179
The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.

Input

One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).

Output

One line for each case, either with a number stating the minimal cost or containing the word Impossible.

Sample Input

3
1033 8179
1373 8017
1033 1033

Sample Output

6
7
0

分析:简单广搜+判断素数。

#include <iostream>
#include <cstring>
#include <cstdio>
#include <queue>

using namespace std;

bool visit[10000];
bool prime[10000];
int x, y, f;
int dd[] = {1000, 100, 10, 1};

struct Data 
{
	int num;
	int sum;
};

queue<Data>q;

void fun()//筛法求素数
{
	prime[1] = 1;
	prime[2] = 0;
	for (int i = 2; i <= 100; i++)
	{
		if (!prime[i])
		{
			int j = i * 2;
			while (j < 10000)
			{
				prime[j] = 1;
				j = j + i;
			}
		}
	}
}

int main()
{
	int n;
	scanf("%d", &n);
	fun();
	while (n--)
	{
		f = 0;
		scanf("%d%d", &x, &y);
		memset(visit, 0, sizeof(visit));
		if (x == y)
		{
			printf("0\n");
			continue;
		}
		Data data;
		data.num = x;
		data.sum = 0;
		q.push(data);
		visit[x] = 1;
		int b[4];
		while (!q.empty())
		{
			data = q.front();
			q.pop();
			b[0] = data.num / 1000;
		   	b[1] = data.num / 100 % 10;
		   	b[2] = data.num / 10 % 100 - b[1] * 10;
		   	b[3] = data.num % 1000 - b[1] * 100 - b[2] * 10;//把四位数分离
			for (int i = 0; i < 4; i++)
			{
				int l = 1;
				for (int k = (b[i] + 1) % 10; l <= 9; l++, k = (k + 1) % 10)//变化其中一位
				{
					int sum = 0;
					for (int j = 0; j < 4; j++)
					{
						if (j == i)
							sum += k * dd[i];
						else 
							sum += b[j] * dd[j];
					}//求和
					if (sum / 1000 == 0)
						continue;
					if (sum == y)
					{
						printf("%d\n", data.sum + 1);
						f = 1;
						break;
					}
					if (!visit[sum] && !prime[sum])
					{
						Data c;
						c.num = sum;
						c.sum = data.sum + 1;
						visit[sum] = 1;
						q.push(c);
					}
				}
				if (f == 1)
					break;
			}
			if (f == 1)
				break;
		}
		while (!q.empty())
			q.pop();
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值