7 七个百分比编码

2.输入描述
输入由一个或多个字符串组成,每个字符串由 1~79 个字符构成且在一行上,以“#”
号结束。全部输入数据中,只在最后包含一个“#”号,不会出现在其他地方。一个字符串
可能包含多个空格,但空格不出现在字符串的开头和结尾位置,也不会连续出现两个或两
个以上的空格。
3.输出描述
对于每个测试案例,使用表中的7 种百分比将保留字符替代,每个测试案例输出一行。
注意,星号的百分比替代符是%2a(这里是小写字母a),而不是%2A(这里是大写字母A)。
4.输入样例
Happy Joy Joy!
http://icpc.baylor.edu/icpc/
plain_vanilla
(**)
?
the 7% solution
#
5.输出样例
Happy%20Joy%20Joy%21
http://icpc.baylor.edu/icpc/
plain_vanilla
%28%2a%2a%29
?

the%207%25%20solution


#include<iostream>
#include<fstream>
#include<string>
using namespace std;
int _tmain(int argc, _TCHAR* argv[])
{
	string t;
	char temp[80];
	ifstream in("D:\\visual studio 2013 code\\test.txt");
	while (in.getline(temp,80))
	{
		if (temp[0] == '#') break;
		t = temp;
		for (int i = 0; i < t.size(); i++)
		{
			if (t[i] == ' ') cout << "%20";
			else if (t[i] == '$')cout << "%24";
			else if (t[i] == '!')cout << "%21";
			else if (t[i] == '%')cout << "25";
			else if (t[i] == '(')cout << "28";
			else if (t[i] == ')')cout << "29";
			else if (t[i] == '*')cout << "2a";
			else
				cout << t[i];
		}
		cout << endl;
	}
	
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值