nyoj最小步数

最少步数

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 4
描述

这有一个迷宫,有0~8行和0~8列:

 1,1,1,1,1,1,1,1,1
 1,0,0,1,0,0,1,0,1
 1,0,0,1,1,0,0,0,1
 1,0,1,0,1,1,0,1,1
 1,0,0,0,0,1,0,0,1
 1,1,0,1,0,1,0,0,1
 1,1,0,1,0,1,0,0,1
 1,1,0,1,0,0,0,0,1
 1,1,1,1,1,1,1,1,1

0表示道路,1表示墙。

现在输入一个道路的坐标作为起点,再如输入一个道路的坐标作为终点,问最少走几步才能从起点到达终点?

(注:一步是指从一坐标点走到其上下左右相邻坐标点,如:从(3,1)到(4,1)。)

输入
第一行输入一个整数n(0<n<=100),表示有n组测试数据;
随后n行,每行有四个整数a,b,c,d(0<=a,b,c,d<=8)分别表示起点的行、列,终点的行、列。
输出
输出最少走几步。
样例输入
2
3 1  5 7
3 1  6 7
样例输出
12
11




代码




#include<stdio.h> 
#include<queue>
#include<stdlib.h>
#include<string.h>
using namespace std; 

struct node
{
	int x;
	int y;
	int t;
};

queue<node>q;
int a[9][9] = {									//外面已经有了一道墙
	{1,1,1,1,1,1,1,1,1},
	{1,0,0,1,0,0,1,0,1},
	{1,0,0,1,1,0,0,0,1},
	{1,0,1,0,1,1,0,1,1},
	{1,0,0,0,0,1,0,0,1},
	{1,1,0,1,0,1,0,0,1},
	{1,1,0,1,0,1,0,0,1},
	{1,1,0,1,0,0,0,0,1},
	{1,1,1,1,1,1,1,1,1}
};
int k[4][2] = {-1, 0, 0, 1, 1, 0, 0, -1};			//表示上下左右四个方向 
int b[9][9];

int e, f, c, d;

void bfs(int x, int y);

int main()
{
	int n;
	scanf("%d", &n);
	while(n--)
	{
		memset(b, 0, sizeof(b));					//标记数组 
		while(!q.empty())							//每次都将队列清空 
			q.pop();
		scanf("%d%d%d%d", &e, &f, &c, &d);
		if(e == c && f == d)
		{
			printf("0\n");
			continue;
		}
		bfs(e, f);
	}
	return 0;
}

void bfs(int e, int f)
{
	node s, w;
	int i;
	s.x = e;
	s.y = f;
	s.t = 0;
	q.push(s);
	b[e][f] = 1;	
	
	while(!q.empty())
	{
		w = q.front();
		
		q.pop();					//首先将第一个出队列 
		for(i = 0; i < 4; i++)			// 分别判断四个方向 
		{
			s.x = w.x + k[i][0];
			s.y = w.y + k[i][1];
			s.t = w.t + 1;
			
			if(s.x == c && s.y == d)
			{
				printf("%d\n", s.t);
				return ;
			}
			if(!b[s.x][s.y] && a[s.x][s.y] == 0)		//如果没有被标记并且有路可走 
			{
				b[s.x][s.y] = 1;
				q.push(s);
			}
		}		
	}
}







评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值