二分查找:hdu 2199 Can you solve this equation?

Can you solve this equation?

Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
 

Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
 

Sample Input
  
  
2 100 -4
 

Sample Output
  
  
1.6152 No solution!
解题思路:

1.建立函数f(x)=8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 - Y,将问题转换为在区间[0,100]上用二分法求方程f(x)=0的根,注意控制精度exp

2.二分思想的应用

</pre><pre name="code" class="cpp">#include <iostream>
#include <cstdio>
#include <algorithm>
#include <map>
#include <vector>
#include <cstring>
#include<cmath>
#define maxn 100010
#define eps 1e-6
using namespace std;
double y;
double f(double x){return 8*pow(x,4)+7*pow(x,3)+2*pow(x,2)+3*x+6-y;}
double bsearch()
{
    double x=0,y=100;
    double m;
    while(y-x>=eps){
        m=(y+x)/2;
        if(f(m)>0) y=m;else x=m;
    }
    return m;
}
int main()
{
   // freopen("input.txt","r",stdin);
   int T;cin>>T;
   while(T--){
    cin>>y;
    if(f(0)*f(100)>0)  cout<<"No solution!"<<endl;
    else{
       printf("%.4lf\n",bsearch());
    }
   }
    return 0;
}


新手上路,望高手不吝赐教,谢谢!~害羞害羞害羞



  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值