hdu1232 - 畅通工程 (并查集)

畅通工程

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 30500    Accepted Submission(s): 16018


Problem Description
某省调查城镇交通状况,得到现有城镇道路统计表,表中列出了每条道路直接连通的城镇。省政府“畅通工程”的目标是使全省任何两个城镇间都可以实现交通(但不一定有直接的道路相连,只要互相间接通过道路可达即可)。问最少还需要建设多少条道路?
 

Input
测试输入包含若干测试用例。每个测试用例的第1行给出两个正整数,分别是城镇数目N ( < 1000 )和道路数目M;随后的M行对应M条道路,每行给出一对正整数,分别是该条道路直接连通的两个城镇的编号。为简单起见,城镇从1到N编号。
注意:两个城市之间可以有多条道路相通,也就是说
3 3
1 2
1 2
2 1
这种输入也是合法的
当N为0时,输入结束,该用例不被处理。
 

Output
对每个测试用例,在1行里输出最少还需要建设的道路数目。
 

Sample Input
  
  
4 2 1 3 4 3 3 3 1 2 1 3 2 3 5 2 1 2 3 5 999 0 0
 

Sample Output
  
  
1 0 2 998
Hint
Hint
Huge input, scanf is recommended.
 
                 做的第一道关于并查集的题,感觉还不错,哈哈
/******************************
*
*	acm:   hdu-1232
*
*	title: 畅通工程
*
*	time:  2014.8.6
*
*******************************/

//赤裸裸的并查集

#include <stdio.h>
#include <stdlib.h>

//-------------  树的双亲表示法结点结构定义 --------------//

#define MAX_TREE_SIZE 1001

typedef int TElemType;

typedef struct PTNode  //结点结构
{
 //   TElemType data;
    int parent;
} PTNode;

/*
typedef struct PTree
{
    PTNode nodes[MAX_TREE_SIZE];
    int r;    //根的位置
    int n;    //结点树
} PTree;
*/

//-------------  树的双亲表示法结点结构定义end --------------//

PTNode nodes[MAX_TREE_SIZE];


//查操作  找到i 的根结点
int find_Eq(PTNode Tr[], int i)
{
    int j;
    int k;
    int temp;

    j = i;
    k = i;

    while (Tr[j].parent > 0)
    {
        j = Tr[j].parent;
    }

	 //路径压缩查找算法
    while (k != j)  //本循环修改查找路径中所有节点 将其都修改为根孩子结点
    {               //以便下次查找的时候速度更快
        temp = Tr[k].parent;
        Tr[k].parent = j;
        k = temp;
    }

    return j;
}


//并操作 (将两个相关集合合并到一起)
void union_Eq(PTNode Tr[], int i, int j)
{
    int temp;  //temp里是合并后子树种结点(负)个数
    int fi;   //i的根结点
    int fj;   //j的根结点

    fi = find_Eq(Tr, i);   //找到i的根节点 赋值
    fj = find_Eq(Tr, j);

    if (fi != fj)  //如果不在一颗树上
    {
        temp = Tr[fi].parent + Tr[fj].parent;

		//将深度小的树合并到深度大的树 
		//避免查找过程中遇到最坏的情况
        if (Tr[fi].parent > Tr[fj].parent)
        {
            Tr[fi].parent = fj;
            Tr[fj].parent = temp;
        }
        else
        {
            Tr[fj].parent = fi;
            Tr[fi].parent = temp;
        }
    }
}


int main()
{
    int N;   //城市数目
    int M;   //道路数目
    int i;
    int a, b;

    while (scanf("%d", &N), N)
    {
        int num = -1;

        scanf("%d", &M);
        //初始化
        for (i = 1; i <= N; i++)
        {
            nodes[i].parent = -1;
        }

        for (i = 0; i < M; i++)
        {
            scanf("%d%d", &a, &b);
            union_Eq(nodes, a, b);
        }

        for (i = 1; i <= N; i++)
        {
            if (nodes[i].parent < 0)
            {
                num++;
            }
        }

        printf("%d\n", num);
    }


    return 0;
}

 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值