poj2387 - Til the Cows Come Home(最短路径问题) (Dijkstra)

Til the Cows Come Home
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 30369 Accepted: 10266

Description

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90

Hint

INPUT DETAILS:

There are five landmarks.

OUTPUT DETAILS:

Bessie can get home by following trails 4, 3, 2, and 1.

Source

                              理解题意总是略坑的过程,这道题的边还可以重复,这想到真费事!而且这道题需要开的数组略大啊,一开始做事用结构体MGraph,可惜溢出。。。
 
/*********************************
*
*	acm:   poj-2387
*
*	title: Til the Cows Come Home
*
*	time : 2014.8.27
*
**********************************/

/*
     输入输出:
           T表示路径,N表示农场(1-N).
           接下来输入T行 每行3个变量,第一第二个变量为路径的坐标,第三个变量为距离
           输出从N到1的最短路径
    思路:
           构建无向图(因为双向),Dijkstra算法 求最短路径。

    提示: 此题会出现重复边的情况,取较小边即可
*/

#include <stdio.h>
#include <stdlib.h>

#define MAXVEX 1001
#define MAXEDGE 2001

#define INFINITY 201000

#define OK 1
#define ERROR 0

#define TRUE 1
#define FALSE 0


int arc[MAXVEX][MAXVEX];
int numVertexes;
int numEdges;


void CreateMGraph()
{
    int i, j;
    int a, b, w;

    for (i = 1; i <= numVertexes; i++)
    {
        for (j = i; j <= numVertexes; j++)
        {
            if (i == j)
            {
                arc[i][j] = 0;
            }
            else
            {
                arc[i][j] = arc[j][i] = INFINITY;
            }
        }
    }

    for (i = 0; i < numEdges; i++)
    {
        scanf("%d%d%d", &a, &b, &w);

        if (arc[a][b] > w)   //重边的情况取较小的路径
        {
            arc[a][b] = w;
            arc[b][a] = w;
        }


    }
}

typedef int ShortPathTable[MAXVEX];

int ShortestPath_Dijkstra()
{
    int v, w, k, min;
    int final[MAXVEX];  //final[w] = 1表示求得顶点v0至vw的最短路径
    ShortPathTable D;

    for (v = 1; v <= numVertexes; v++)
    {
        final[v] = 0;
        D[v] = arc[1][v];
    }

    final[1] = 1;

    for (v = 2; v <= numVertexes; v++)
    {
        min = INFINITY;

        for (w = 1; w <= numVertexes; w++)
        {
            if (!final[w] && D[w] < min)
            {
                k = w;
                min = D[w];
            }
        }

        final[k] = 1;

        if (final[numVertexes] == 1)
        {
            break;
        }

        for (w = 1; w <= numVertexes; w++)
        {
            //如果v顶点的路径比现在这条短的话
            if (!final[w] && min + arc[k][w] < D[w])
            {
                D[w] = min + arc[k][w];
            }
        }

    }

    return D[numVertexes];
}

int main()
{

    while (~scanf("%d%d", &numEdges, &numVertexes))
    {
        CreateMGraph();
        printf("%d\n", ShortestPath_Dijkstra());
    }

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值